#29143 closed enhancement (fixed)

tox.ini update: Fix breakage caused by src/ext move, add 32-bit linux environments and other architectures supported by docker

Reported by: mkoeppe Owned by:
Priority: major Milestone: sage-9.1
Component: porting Keywords:
Cc: vbraun, tmonteil, fbissey, dimpase Merged in:
Authors: Matthias Koeppe Reviewers: Volker Braun
Report Upstream: N/A Work issues:
Branch: 7f122bd (Commits, GitHub, GitLab) Commit: 7f122bdda3253eeb23cef16c495491890f712959
Dependencies: Stopgaps:

Status badges

Description (last modified by mkoeppe)

#29053 added tox.ini to support testing the sage distribution in isolated environments via docker.

In 9.1.beta6, the generated docker files do not work due to #21785.

This ticket fixes it and also adds linux environments for various other architectures supported by docker (see https://github.com/docker-library/official-images#architectures-other-than-amd64).

Examples:

$ tox -e docker-debian-buster-standard-i386
$ tox -e docker-ubuntu-bionic-standard-arm64
$ tox -e docker-ubuntu-bionic-minimal-armhf
$ tox -e docker-fedora-31-standard-arm64v8         # Docker for Mac only
$ tox -e docker-ubuntu-latest-standard-s390x       # Docker for Mac only

(The last two work with macOS Docker Desktop because it has binfmt_misc with qemu enabled.)

See also: https://trac.sagemath.org/wiki/ExoticPorts


Resources:

Change History (23)

comment:1 Changed 15 months ago by mkoeppe

  • Description modified (diff)

comment:2 Changed 15 months ago by mkoeppe

  • Dependencies set to #29053, #29104

on top of #29104 to avoid merge conflicts

comment:3 Changed 15 months ago by mkoeppe

  • Branch set to u/mkoeppe/add_to_tox_ini_some_32_bit_linux_environments

comment:4 Changed 15 months ago by mkoeppe

  • Commit set to 839d6fbb5685b21b03fdb61cac352fae7611b186
  • Description modified (diff)
  • Status changed from new to needs_review
  • Summary changed from Add to tox.ini some 32-bit linux environments to Add to tox.ini 32-bit linux environments and other architectures supported by docker

Last 10 new commits:

98edff6Add build/pkgs/gfortran/distros/fedora.txt
843ca76build/pkgs/fedora.txt: Add python3
bd6a545tox.ini: Add debian stretch, put sid last
23c6334build/pkgs/openblas/distros/arch.txt: Add lapack, cblas
fca6654tox.ini: Add toxenvs local-homebrew-macos-minimal, local-homebrew-macos-standard
e0e8a4ctox.ini [local-homebrew]: Fixup PATH, PKG_CONFIG_PATH, set LDFLAGS, CPPFLAGS; [local-direct]: New
16ca88ftox.ini: Use {envlogdir}; use ln -sf
6a1803dtox.ini [local]: First build the base-toolchain
4b72987tox.ini [local-homebrew]: Set PATH earlier and set ACLOCAL_PATH for bootstrapping
839d6fbtox.ini: Add other archs supported by docker

comment:5 Changed 15 months ago by mkoeppe

  • Authors set to Matthias Koeppe

comment:6 Changed 15 months ago by git

  • Commit changed from 839d6fbb5685b21b03fdb61cac352fae7611b186 to 67e14ce486e6cbb73c50dd9af61a95c2395e1ebd

Branch pushed to git repo; I updated commit sha1. New commits:

67e14cefixup for llocal

comment:7 Changed 15 months ago by mkoeppe

This works on macOS because it is running everything in a virtualbox.

I haven't succeeded in getting it to work on github actions yet. last attempt: https://github.com/mkoeppe/sage/runs/422184737?check_suite_focus=true

comment:8 Changed 15 months ago by mkoeppe

  • Description modified (diff)

comment:9 Changed 15 months ago by mkoeppe

  • Description modified (diff)

comment:10 Changed 14 months ago by git

  • Commit changed from 67e14ce486e6cbb73c50dd9af61a95c2395e1ebd to b5361e25660b4f2f5afd9e48866c6b341ea70cfa

Branch pushed to git repo; I updated commit sha1. This was a forced push. New commits:

2141b75Merge tag '9.1.beta3' into t/29104/tox-homebrew
2b0a25etox.ini: Add other archs supported by docker
e3f832cfixup for llocal
b5361e2tox.ini: Restructure docker image:tag construction, add multiarch for Linux Docker

comment:11 Changed 14 months ago by mkoeppe

  • Description modified (diff)

comment:12 Changed 14 months ago by mkoeppe

  • Dependencies changed from #29053, #29104 to #29104
  • Description modified (diff)

comment:14 Changed 14 months ago by mkoeppe

  • Description modified (diff)

comment:15 Changed 14 months ago by git

  • Commit changed from b5361e25660b4f2f5afd9e48866c6b341ea70cfa to 4350d0a075d7291de9a21b134dc309945bdc0850

Branch pushed to git repo; I updated commit sha1. New commits:

4350d0atox.ini: Add raspbian

comment:16 Changed 14 months ago by mkoeppe

Also this ticket needs review and would facilitate testing on 32bit x86 and ARM

comment:17 Changed 14 months ago by git

  • Commit changed from 4350d0a075d7291de9a21b134dc309945bdc0850 to 59e1d6fb6cfeb0b1effa860e7c4b325fd3fdbdf8

Branch pushed to git repo; I updated commit sha1. New commits:

59e1d6fMerge tag '9.1.beta4' into t/29143/add_to_tox_ini_some_32_bit_linux_environments

comment:18 Changed 14 months ago by git

  • Commit changed from 59e1d6fb6cfeb0b1effa860e7c4b325fd3fdbdf8 to 254753d75d332f231a121e58cabc3aef3b7170b5

Branch pushed to git repo; I updated commit sha1. New commits:

4eb201bMerge tag '9.1.beta4' into t/29104/tox-homebrew
254753dMerge branch 't/29104/tox-homebrew' into t/29143/add_to_tox_ini_some_32_bit_linux_environments

comment:19 Changed 14 months ago by git

  • Commit changed from 254753d75d332f231a121e58cabc3aef3b7170b5 to 7f122bdda3253eeb23cef16c495491890f712959

Branch pushed to git repo; I updated commit sha1. This was a forced push. New commits:

749f83etox.ini: Add other archs supported by docker
e941bd5fixup for llocal
2441fe9tox.ini: Restructure docker image:tag construction, add multiarch for Linux Docker
2f057cbtox.ini: Add raspbian
7f122bdbuild/bin/write-dockerfile.sh: src/ext has moved and is no longer needed for the configure phase

comment:20 Changed 14 months ago by mkoeppe

  • Dependencies #29104 deleted
  • Description modified (diff)
  • Summary changed from Add to tox.ini 32-bit linux environments and other architectures supported by docker to tox.ini update: Fix breakage caused by src/ext move, add 32-bit linux environments and other architectures supported by docker

The branch is no longer on top of #29104 (homebrew).

Needs review.

comment:21 Changed 14 months ago by vbraun

  • Reviewers set to Volker Braun
  • Status changed from needs_review to positive_review

comment:22 Changed 14 months ago by mkoeppe

Thanks!

comment:23 Changed 14 months ago by vbraun

  • Branch changed from u/mkoeppe/add_to_tox_ini_some_32_bit_linux_environments to 7f122bdda3253eeb23cef16c495491890f712959
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.