#29081 closed defect (fixed)

allow proper detection of gf2x 1.3

Reported by: dimpase Owned by:
Priority: major Milestone: sage-9.1
Component: build: configure Keywords:
Cc: arojas, isuruf, fbissey Merged in:
Authors: Dima Pasechnik Reviewers: Antonio Rojas
Report Upstream: N/A Work issues:
Branch: 1ad30fc (Commits, GitHub, GitLab) Commit: 1ad30fc606ffbc55de49431bef2080758b737913
Dependencies: Stopgaps:

Status badges

Description

our current (a very convoluted) test for system's gf2x version 1.2 stumbles on newer gf2x (due to a change in certain function signature). E.g. Arch already has 1.3, so this needs a fix.

An easy fix is to use pkg-config to test for the version, as now gf2x comes with gf2x.pc (I've done a patch for gf2x at some point to fix this :-)).

Change History (10)

comment:1 follow-ups: Changed 21 months ago by dimpase

Antonio, do you know whether using gf2x 1.3.0 needs any doctest patches?

comment:2 in reply to: ↑ 1 Changed 21 months ago by arojas

Replying to dimpase:

Antonio, do you know whether using gf2x 1.3.0 needs any doctest patches?

No, everything works fine

comment:3 Changed 21 months ago by dimpase

  • Branch set to u/dimpase/packages/detect_gf2x_130
  • Cc isuruf fbissey added
  • Commit set to 1ad30fc606ffbc55de49431bef2080758b737913
  • Status changed from new to needs_review
  • Type changed from enhancement to defect

New commits:

1ad30fcallow gf2x vers >= 1.3 to be detected

comment:4 in reply to: ↑ 1 Changed 21 months ago by arojas

Replying to dimpase:

Antonio, do you know whether using gf2x 1.3.0 needs any doctest patches?

Forgot to mention: even though sage itself works fine, ntl<11.4.2 will fail to build. So using gf2x>=1.3 requires using ntl>=11.4.2 or applying this patch:

https://git.archlinux.org/svntogit/community.git/tree/trunk/ntl-gf2x-1.3.patch?h=packages/ntl&id=984d20aef5d675abc756f151cb044944bdb78575

comment:5 follow-up: Changed 21 months ago by dimpase

We can either upgrade NTL in Sage (we should anyway, see #29109) or we can check in our spkg-configure that gf2x is too new and do not configure NTL to use gf2x in this case.

comment:6 in reply to: ↑ 5 Changed 21 months ago by dimpase

Replying to dimpase:

We can either upgrade NTL in Sage (we should anyway, see #29109) or we can check in our spkg-configure that gf2x is too new and do not configure NTL to use gf2x in this case.

with #29109 done, gf2x 1.3.0 may be used without a problem. I've added #29109 as dependency here. So this can go forward too.

comment:7 Changed 21 months ago by arojas

  • Status changed from needs_review to positive_review

Built fine on Arch with system gf2x 1.3

comment:8 Changed 21 months ago by chapoton

please add missing reviewer name

comment:9 Changed 21 months ago by dimpase

  • Reviewers set to Antonio Rojas

comment:10 Changed 21 months ago by vbraun

  • Branch changed from u/dimpase/packages/detect_gf2x_130 to 1ad30fc606ffbc55de49431bef2080758b737913
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.