Opened 2 years ago

Last modified 2 years ago

#29054 closed enhancement

polymake: Make it an error at sage ./configure time if Perl prerequisites are missing — at Initial Version

Reported by: mkoeppe Owned by:
Priority: major Milestone: sage-9.1
Component: packages: experimental Keywords:
Cc: dimpase, jhpalmieri, jipilab, arojas, isuruf, vdelecroix Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

We do this by adding a script package perl_cpan_polymake_prereq (see #27763) with an spkg-configure.m4 that checks for the prerequisites and an spkg-install that always fails.

Simpler than #27763 and more reliable than depending on users reading build/pkgs/polymake/SPKG.txt

Change History (0)

Note: See TracTickets for help on using tickets.