Opened 23 months ago

Closed 5 months ago

#29036 closed defect (invalid)

sage -v cannot work : sage's env hasn't been sourced yet!

Reported by: Snark Owned by:
Priority: minor Milestone: sage-duplicate/invalid/wontfix
Component: scripts Keywords:
Cc: jhpalmieri Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

The problem was reported on Debian, but I checked the source on git to see it was also there upstream.

The problem is that the sage_version function in src/bin/sage is using $SAGE_foo variables, but is called (by itself and through others, like usage and usage_advanced) by functions which are called before the environment has been set. Run where $0-version.sh isn't readily available, it even tries to source a file on a wrong path, which just gives an error.

Change History (4)

comment:1 Changed 19 months ago by mkoeppe

  • Cc jhpalmieri added
  • Milestone changed from sage-9.1 to sage-duplicate/invalid/wontfix
  • Status changed from new to needs_review

Works for me in 9.1.rc2

comment:2 Changed 19 months ago by jhpalmieri

Works for me, too:

% ls
% tar xf ../../tar-files/sage-9.1.rc2.tar.gz 
% cd sage-9.1.rc2 
% ./sage -v
SageMath version 9.1.rc2, Release Date: 2020-04-25

I suppose it could be a Debian problem, or more generally a problem for the distros. @Snark: Is there a reason to keep this open?

comment:3 Changed 9 months ago by jhpalmieri

  • Status changed from needs_review to positive_review

Let's close this. We can open a new ticket if the problem resurfaces.

comment:4 Changed 5 months ago by mkoeppe

  • Resolution set to invalid
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.