Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#28948 closed enhancement (fixed)

some preparation for ipython7

Reported by: chapoton Owned by:
Priority: major Milestone: sage-9.1
Component: refactoring Keywords:
Cc: arojas, embray, tscrim Merged in:
Authors: Frédéric Chapoton Reviewers: John Palmieri
Report Upstream: N/A Work issues:
Branch: b605cd4 (Commits, GitHub, GitLab) Commit:
Dependencies: Stopgaps:

Status badges

Description

to be merged before #28197

This is inspired by some pieces of the patch

https://aur.archlinux.org/cgit/aur.git/tree/sagemath-ipython7.patch?h=sagemath-python3-git

Change History (7)

comment:1 Changed 2 years ago by chapoton

  • Branch set to u/chapoton/28948
  • Commit set to b605cd4529be00b2ce9e32e03831332f42b038c3
  • Status changed from new to needs_review
  • Type changed from PLEASE CHANGE to enhancement

New commits:

b605cd4some preparation for ipython7

comment:2 Changed 2 years ago by chapoton

  • Cc embray tscrim added

bot is morally green, please review

comment:3 Changed 2 years ago by jhpalmieri

  • Reviewers set to John Palmieri
  • Status changed from needs_review to positive_review

Works with Python 3 and Python 2 builds.

comment:4 Changed 2 years ago by chapoton

  • Authors set to Frédéric Chapoton

thx

comment:5 Changed 2 years ago by vbraun

  • Branch changed from u/chapoton/28948 to b605cd4529be00b2ce9e32e03831332f42b038c3
  • Resolution set to fixed
  • Status changed from positive_review to closed

comment:6 Changed 2 years ago by arojas

  • Commit b605cd4529be00b2ce9e32e03831332f42b038c3 deleted

Unfortunately this doesn't really work as intended. The reason why the imp import is an issue with ipython 7 is that, unlike ipython 5, it displays the python deprecation warnings, which makes many tests fail.

With this patch, from imp import reload still succeeds (imp hasn't been removed yet even in 3.8, it is just deprecated), so instead of using impotlib, it still shows the deprecation warnings and tests fail.

comment:7 Changed 2 years ago by arojas

I guess the solution is to try the importlib import first

Note: See TracTickets for help on using tickets.