Opened 2 years ago

Closed 2 years ago

#28919 closed enhancement (fixed)

spkg-configure for tachyon

Reported by: dimpase Owned by:
Priority: major Milestone: sage-9.1
Component: build: configure Keywords:
Cc: fbissey, embray, thansen, infinity0, isuruf, mkoeppe Merged in:
Authors: Dima Pasechnik Reviewers: Isuru Fernando
Report Upstream: N/A Work issues:
Branch: d065952 (Commits, GitHub, GitLab) Commit: d065952d40d066e73e16ba29fe6cdda3827858b0
Dependencies: Stopgaps:

Status badges

Description

as we only need exacutables, this is trivial

Change History (7)

comment:1 Changed 2 years ago by dimpase

  • Status changed from new to needs_review

comment:2 Changed 2 years ago by dimpase

  • Cc fbissey embray thansen infinity0 isuruf mkoeppe added
  • Milestone changed from sage-9.0 to sage-9.1

comment:3 follow-up: Changed 2 years ago by isuruf

Since it's the executables, do we need, SAGE_SPKG_DEPCHECK([libpng]?

comment:4 Changed 2 years ago by git

  • Commit changed from 2b9a898d6046d1820086b19295361b6decf21029 to d065952d40d066e73e16ba29fe6cdda3827858b0

Branch pushed to git repo; I updated commit sha1. This was a forced push. New commits:

d065952spkg-configure for tachyon

comment:5 in reply to: ↑ 3 Changed 2 years ago by dimpase

Replying to isuruf:

Since it's the executables, do we need, SAGE_SPKG_DEPCHECK([libpng]?

indeed, it's not needed, removed.

comment:6 Changed 2 years ago by isuruf

  • Reviewers set to Isuru Fernando
  • Status changed from needs_review to positive_review

There's no version check here, but sage is packaging 0.98.9 which is from 2010, so I think there's no need to check version.

comment:7 Changed 2 years ago by vbraun

  • Branch changed from u/dimpase/packages/tachyonconf to d065952d40d066e73e16ba29fe6cdda3827858b0
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.