Opened 3 years ago

Last modified 5 months ago

#28815 new enhancement

Meta-ticket: Don't pass SAGE_PKGS to src/setup.py. Replace OptionalExtension(...., package=....) by condition=Feature.is_present(), — at Version 6

Reported by: mkoeppe Owned by:
Priority: major Milestone: sage-9.7
Component: build Keywords: sd111
Cc: jdemeyer, arojas, fbissey, dimpase, embray, gh-timokau, isuruf, jhpalmieri Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description (last modified by mkoeppe)

Tickets:

Alternative approaches:

Change History (6)

comment:1 Changed 3 years ago by mkoeppe

  • Dependencies set to #25828

comment:2 Changed 3 years ago by embray

  • Milestone changed from sage-9.0 to sage-9.1

Ticket retargeted after milestone closed

comment:3 Changed 3 years ago by mkoeppe

  • Cc isuruf added

comment:4 Changed 2 years ago by mkoeppe

  • Milestone changed from sage-9.1 to sage-9.2

comment:5 Changed 2 years ago by mkoeppe

  • Cc jhpalmieri added

comment:6 Changed 2 years ago by mkoeppe

  • Dependencies #25828 deleted
  • Description modified (diff)
  • Summary changed from Don't pass SAGE_PKGS to src/setup.py. Replace OptionalExtension(...., package=....) by condition=Feature.is_present(), to Meta-ticket: Don't pass SAGE_PKGS to src/setup.py. Replace OptionalExtension(...., package=....) by condition=Feature.is_present(),
Note: See TracTickets for help on using tickets.