#28798 closed defect (duplicate)

segmentation fault contraction tensor

Reported by: gh-LBrunswic Owned by:
Priority: critical Milestone: sage-duplicate/invalid/wontfix
Component: linear algebra Keywords: Tensors, parallelism, segmentation fault
Cc: egourgoulhon Merged in:
Authors: Léo Brunswic Reviewers: Eric Gourgoulhon
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

The following code generates a segfault in sage-shell. In the notebook, we get a TypeError? and a kernel crash.

Parallelism().set(nproc=2) 
M = FiniteRankFreeModule(SR, 3, name='M')
e  = M.basis('e')
x,y,z,t = var("x,y,z,t")                 
Theta = M.tensor((1,1))
for i in range(3):
    for j in range(3):
        Theta[i,j] = function("Theta_"+str(i)+str(j))(x,y,z,t)
Theta["^i_j"]*Theta["^j_i"]  

Note that the error does not occur if one replaces Parallelism().set(nproc=2) by Parallelism().set(nproc=1)

Furthermore, this error did not occur in sage8.9

Change History (6)

comment:1 Changed 17 months ago by gh-LBrunswic

I Tried to find a simpler version of the bug. It does not occur if one replace symbolic functions by a variable.

comment:2 Changed 17 months ago by egourgoulhon

  • Milestone changed from sage-9.0 to sage-duplicate/invalid/wontfix
  • Status changed from new to needs_review

This is a duplicate of #27492.

comment:3 follow-up: Changed 17 months ago by gh-LBrunswic

I'm sorry!

comment:4 in reply to: ↑ 3 Changed 17 months ago by egourgoulhon

Replying to gh-LBrunswic:

I'm sorry!

No problem. Before opening a ticket for a bug, you may have a look at the bug section of the metaticket #18528 to check if a ticket has not been already opened.

comment:5 Changed 17 months ago by egourgoulhon

  • Reviewers set to Eric Gourgoulhon
  • Status changed from needs_review to positive_review

I am marking the ticket as "positive review" so that it can be closed with the resolution flag set to duplicate.

comment:6 Changed 17 months ago by chapoton

  • Resolution set to duplicate
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.