Opened 14 years ago

Closed 14 years ago

#2878 closed defect (fixed)

[with patch; positive review] notebook -- cython .c and .html links should open in new links (use target="_new"

Reported by: was Owned by: boothby
Priority: major Milestone: sage-3.0
Component: notebook Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description (last modified by was)

Do this, because otherwise user (1) clicks html or c link, then (2) sees the html or c, then (3) presses browser back button, then (4) PANICS! since all their work is gone (actually they can get it back by pressing refresh). This is VERY confusing, and I've had users ask about it multiple times recently.

Alternatively, is there a way so that when a user navigates to a worksheet page via the back button, the page is automatically refreshed?

Attachments (1)

sage-2878.patch (955 bytes) - added by was 14 years ago.

Download all attachments as: .zip

Change History (5)

comment:1 Changed 14 years ago by was

  • Description modified (diff)

Changed 14 years ago by was

comment:2 Changed 14 years ago by was

  • Summary changed from notebook -- cython .c and .html links should open in new links (use target="_new" to [with patch; needs review] notebook -- cython .c and .html links should open in new links (use target="_new"

comment:3 Changed 14 years ago by boothby

  • Summary changed from [with patch; needs review] notebook -- cython .c and .html links should open in new links (use target="_new" to [with patch; positive review] notebook -- cython .c and .html links should open in new links (use target="_new"

"Alternatively, is there a way so that when a user navigates to a worksheet page via the back button, the page is automatically refreshed?"

This is a hard problem. Let's think about making a new ticket out of that issue (because the problem is ultimately larger than these links), and take this patch for now.

comment:4 Changed 14 years ago by mabshoff

  • Resolution set to fixed
  • Status changed from new to closed

Merged in Sage 3.0.alpha4

Note: See TracTickets for help on using tickets.