Opened 3 years ago

Closed 2 years ago

#28623 closed enhancement (fixed)

Upgrade Arb to 2.18.1

Reported by: Fredrik Johansson Owned by:
Priority: major Milestone: sage-9.3
Component: packages: standard Keywords:
Cc: Marc Mezzarobba, Vincent Delecroix, François Bissey, Antonio Rojas Merged in:
Authors: Matthias Koeppe, Dima Pasechnik Reviewers: Dima Pasechnik, Matthias Koeppe
Report Upstream: N/A Work issues:
Branch: 0c9c4ed (Commits, GitHub, GitLab) Commit: 0c9c4ed35c2eaf34ae0d19387c07b7f460e4abce
Dependencies: Stopgaps:

Status badges

Description (last modified by Matthias Köppe)

http://arblib.org/history.html#history

adds support for FLINT 2.6 (#29719)

tarball: See checksums.ini [upstream_url]

Change History (65)

comment:1 Changed 3 years ago by François Bissey

Cc: François Bissey added

comment:2 Changed 3 years ago by Erik Bray

Milestone: sage-9.0sage-9.1

Ticket retargeted after milestone closed

comment:3 Changed 3 years ago by Matthias Köppe

Milestone: sage-9.1sage-9.2

comment:4 Changed 2 years ago by Matthias Köppe

Description: modified (diff)
Summary: Upgrade Arb to 2.17.0Upgrade Arb to 2.18.0

comment:5 Changed 2 years ago by Matthias Köppe

Branch: u/mkoeppe/upgrade_arb_to_2_18_0

comment:6 Changed 2 years ago by Matthias Köppe

Authors: Matthias Koeppe
Commit: e7a25cb0d7c775a182f63e5fd5aeb18807fabd61

New commits:

f9be33abuild/pkgs/arb: Update to 2.18.0
e7a25cbbuild/pkgs/arb/patches/silence-stderr-exponent-too-large.patch: Remove

comment:7 Changed 2 years ago by Matthias Köppe

Description: modified (diff)

comment:8 Changed 2 years ago by Matthias Köppe

Status: newneeds_review

comment:9 Changed 2 years ago by Timo Kaufmann

Have you run the testsuite? I just tried to do the update for sage in nixpkgs. We're still on sage 8.9, but I expect the failures would be the same with the current develop branch as the tests are still the same. Most of the test failures are due to precision improvements, but two (the nans) look like regressions:

sage -t --long /nix/store/6dnh3dcsfmj8akrifqy95wd57sfnprp6-sage-src-8.9/src/sage/rings/complex_arb.pyx
**********************************************************************
File "/nix/store/6dnh3dcsfmj8akrifqy95wd57sfnprp6-sage-src-8.9/src/sage/rings/complex_arb.pyx", line 4510, in sage.rings.complex_arb.ComplexBall.elliptic_pi
Failed example:
    CBF(2,3).elliptic_pi(CBF(1,1))
Expected:
    [0.27029997361983 +/- ...e-15] + [0.715676058329095 +/- ...e-16]*I
Got:
    [0.2702999736198 +/- 4.51e-14] + [0.7156760583291 +/- 1.78e-14]*I
**********************************************************************
File "/nix/store/6dnh3dcsfmj8akrifqy95wd57sfnprp6-sage-src-8.9/src/sage/rings/complex_arb.pyx", line 4618, in sage.rings.complex_arb.ComplexBall.elliptic_pi_inc
Failed example:
    n.elliptic_pi_inc(CBF.pi()/2, m)
Expected:
    [0.8934793755173 +/- ...e-14] + [0.95707868710750 +/- ...e-15]*I
Got:
    nan + nan*I
**********************************************************************
File "/nix/store/6dnh3dcsfmj8akrifqy95wd57sfnprp6-sage-src-8.9/src/sage/rings/complex_arb.pyx", line 4620, in sage.rings.complex_arb.ComplexBall.elliptic_pi_inc
Failed example:
    n.elliptic_pi(m)
Expected:
    [0.89347937551733 +/- ...e-15] + [0.95707868710750 +/- ...e-15]*I
Got:
    [0.8934793755173 +/- 4.27e-14] + [0.9570786871075 +/- 9.91e-15]*I
**********************************************************************
File "/nix/store/6dnh3dcsfmj8akrifqy95wd57sfnprp6-sage-src-8.9/src/sage/rings/complex_arb.pyx", line 4625, in sage.rings.complex_arb.ComplexBall.elliptic_pi_inc
Failed example:
    n.elliptic_pi_inc(CBF.pi()/2, m)
Expected:
    [0.2969588746419 +/- ...e-14] + [1.3188795332738 +/- ...e-14]*I
Got:
    nan + nan*I
**********************************************************************
File "/nix/store/6dnh3dcsfmj8akrifqy95wd57sfnprp6-sage-src-8.9/src/sage/rings/complex_arb.pyx", line 4627, in sage.rings.complex_arb.ComplexBall.elliptic_pi_inc
Failed example:
    n.elliptic_pi(m)
Expected:
    [0.29695887464189 +/- ...e-15] + [1.31887953327376 +/- ...e-15]*I
Got:
    [0.2969588746419 +/- 3.79e-14] + [1.3188795332738 +/- 7.19e-14]*I
**********************************************************************
File "/nix/store/6dnh3dcsfmj8akrifqy95wd57sfnprp6-sage-src-8.9/src/sage/rings/complex_arb.pyx", line 4703, in sage.rings.complex_arb.ComplexBall.elliptic_rj
Failed example:
    CBF(0,1).elliptic_rj(CBF(-1/2,1), CBF(-1,-1), CBF(2))
Expected:
    [1.004386756285733 +/- ...e-16] + [-0.2451626834391645 +/- ...e-17]*I
Got:
    [1.00438675628573 +/- 6.85e-15] + [-0.24516268343916 +/- 8.11e-15]*I
**********************************************************************
3 items had failures:
   1 of   2 in sage.rings.complex_arb.ComplexBall.elliptic_pi
   4 of  10 in sage.rings.complex_arb.ComplexBall.elliptic_pi_inc
   1 of   2 in sage.rings.complex_arb.ComplexBall.elliptic_rj
    [637 tests, 6 failures, 7.92 s]
File "/nix/store/6dnh3dcsfmj8akrifqy95wd57sfnprp6-sage-src-8.9/src/sage/rings/real_arb.pyx", line 295, in sage.rings.real_arb.arb_to_mpfi
Failed example:
    RIF(RBF(2)**(2**100)) # indirect doctest
Expected:
    Traceback (most recent call last):
    ...
    ArithmeticError: Error converting arb to mpfi. Overflow?
Got:
    [5.8756537891115869e1388255822130839282 .. +infinity]
**********************************************************************
File "/nix/store/6dnh3dcsfmj8akrifqy95wd57sfnprp6-sage-src-8.9/src/sage/rings/real_arb.pyx", line 1657, in sage.rings.real_arb.RealBall.mid
Failed example:
    b.mid()
Expected:
    Traceback (most recent call last):
    ...
    RuntimeError: unable to convert to MPFR (exponent out of range?)
Got:
    +infinity
**********************************************************************
2 items had failures:
   1 of   7 in sage.rings.real_arb.RealBall.mid
   1 of   2 in sage.rings.real_arb.arb_to_mpfi
    [539 tests, 2 failures, 0.71 s]

comment:10 Changed 2 years ago by Matthias Köppe

Status: needs_reviewneeds_work

comment:11 Changed 2 years ago by Dima Pasechnik

Reviewers: Dima Pasechnik
Status: needs_workpositive_review

I don't see these arb errors if I update flint to 2.6 in lockstep with arb.

comment:12 Changed 2 years ago by Timo Kaufmann

I get the same errors if I update flint as well, but if you're not seeing them that could also be caused by some other dependency / version difference of sage on nix.

comment:13 Changed 2 years ago by Dima Pasechnik

our flint 2.6.0 update ticket has patches, did you use them?

comment:14 in reply to:  11 Changed 2 years ago by Matthias Köppe

Replying to dimpase:

I don't see these arb errors if I update flint to 2.6 in lockstep with arb.

Perhaps then this ticket should depend on the FLINT ticket, not the other way around; or we should close this one and use #29719 for both updates.

comment:15 in reply to:  13 Changed 2 years ago by Timo Kaufmann

Replying to dimpase:

our flint 2.6.0 update ticket has patches, did you use them?

No, but I don't see any relevant patches either. Only 0001-Makefile.in-macos-Do-not-make-DESTDIR-part-of-instal.patch was added, which is both MacOS and buildsystem specific.

comment:16 Changed 2 years ago by Dima Pasechnik

Dependencies: #29719

some needed for doctests patches for arb are on #29719. Sorry for mess.

comment:17 Changed 2 years ago by Volker Braun

Status: positive_reviewneeds_work

comment:18 Changed 2 years ago by Dima Pasechnik

Milestone: sage-9.2sage-duplicate/invalid/wontfix
Status: needs_workneeds_review

comment:19 Changed 2 years ago by Dima Pasechnik

Status: needs_reviewpositive_review

further work on this to happen on #29719.

comment:20 Changed 2 years ago by Frédéric Chapoton

Resolution: duplicate
Status: positive_reviewclosed

comment:21 Changed 2 years ago by Matthias Köppe

Milestone: sage-duplicate/invalid/wontfixsage-9.2
Resolution: duplicate
Status: closednew

#29719 no longer updates arb

comment:22 Changed 2 years ago by Matthias Köppe

The failures reported in comment 9 have been reproduced in the Sage distribution, see #29719.

comment:23 Changed 2 years ago by Antonio Rojas

Cc: Antonio Rojas added

comment:24 Changed 2 years ago by Matthias Köppe

Authors: Matthias KoeppeMatthias Koeppe, ...

This ticket needs some help from someone who is familiar with these tests

comment:25 in reply to:  9 Changed 2 years ago by Marc Mezzarobba

Hello everyone,

Little time for Sage development these days, sorry!

Replying to gh-timokau:

**********************************************************************
File "/nix/store/6dnh3dcsfmj8akrifqy95wd57sfnprp6-sage-src-8.9/src/sage/rings/complex_arb.pyx", line 4510, in sage.rings.complex_arb.ComplexBall.elliptic_pi
Failed example:
    CBF(2,3).elliptic_pi(CBF(1,1))
Expected:
    [0.27029997361983 +/- ...e-15] + [0.715676058329095 +/- ...e-16]*I
Got:
    [0.2702999736198 +/- 4.51e-14] + [0.7156760583291 +/- 1.78e-14]*I

This output change and all similar ones (slight increases in radius) are benign. The expected output could be replaced by something like

    [0.2702999736198...] + [0.715676058329...]*I

to stay compatible with both versions of arb.

The following two changes are in fact welcome improvements:

File "/nix/store/6dnh3dcsfmj8akrifqy95wd57sfnprp6-sage-src-8.9/src/sage/rings/real_arb.pyx", line 295, in sage.rings.real_arb.arb_to_mpfi
Failed example:
    RIF(RBF(2)**(2**100)) # indirect doctest
Expected:
    Traceback (most recent call last):
    ...
    ArithmeticError: Error converting arb to mpfi. Overflow?
Got:
    [5.8756537891115869e1388255822130839282 .. +infinity]
**********************************************************************
File "/nix/store/6dnh3dcsfmj8akrifqy95wd57sfnprp6-sage-src-8.9/src/sage/rings/real_arb.pyx", line 1657, in sage.rings.real_arb.RealBall.mid
Failed example:
    b.mid()
Expected:
    Traceback (most recent call last):
    ...
    RuntimeError: unable to convert to MPFR (exponent out of range?)
Got:
    +infinity
**********************************************************************
2 items had failures:
   1 of   7 in sage.rings.real_arb.RealBall.mid
   1 of   2 in sage.rings.real_arb.arb_to_mpfi
    [539 tests, 2 failures, 0.71 s]

I'm not sure about the remaining two failures. Maybe Fredrik can comment.

**********************************************************************
File "/nix/store/6dnh3dcsfmj8akrifqy95wd57sfnprp6-sage-src-8.9/src/sage/rings/complex_arb.pyx", line 4618, in sage.rings.complex_arb.ComplexBall.elliptic_pi_inc
Failed example:
    n.elliptic_pi_inc(CBF.pi()/2, m)
Expected:
    [0.8934793755173 +/- ...e-14] + [0.95707868710750 +/- ...e-15]*I
Got:
    nan + nan*I
**********************************************************************
**********************************************************************
File "/nix/store/6dnh3dcsfmj8akrifqy95wd57sfnprp6-sage-src-8.9/src/sage/rings/complex_arb.pyx", line 4625, in sage.rings.complex_arb.ComplexBall.elliptic_pi_inc
Failed example:
    n.elliptic_pi_inc(CBF.pi()/2, m)
Expected:
    [0.2969588746419 +/- ...e-14] + [1.3188795332738 +/- ...e-14]*I
Got:
    nan + nan*I
**********************************************************************

comment:26 Changed 2 years ago by Fredrik Johansson

As I already commented in #29719:

The slight regressions in accuracy for elliptic_pi, elliptic_pi_inc and elliptic_rj are due to using a different algorithm to compute the R_J function for certain complex parameters. The new algorithm is a bit slower and less accurate, but unlike the old algorithm always gives the right branch. These doctest results just need to be updated.

Unfortunately, the new algorithm doesn't work when phi is an inexact multiple of pi/2, leading to the NaN values. There is a workaround: acb_elliptic_pi_inc takes a pi flag to multiply the argument by pi exactly, so if you add a pi flag to the Sage wrapper and pass in phi=0.5 with pi=True in the doctest, it should give the expected result.

It's theoretically possible to fix these regressions, and I will open an Arb issue for it, but I'm not keen to spend time on it any time soon.

The other two examples look correct: converting an Arb number to an MPFR now rounds according to MPFR semantics (including rounding to infinity) instead of abort()ing when the exponents are out of range for MPFR.

comment:27 Changed 2 years ago by Matthias Köppe

Milestone: sage-9.2sage-9.3

comment:28 Changed 2 years ago by Matthias Köppe

Dependencies: #29719#29719, #30486

comment:29 Changed 2 years ago by Dima Pasechnik

Branch: u/mkoeppe/upgrade_arb_to_2_18_0u/dimpase/upgrade_arb_to_2_18_0
Commit: e7a25cb0d7c775a182f63e5fd5aeb18807fabd61387ba00399b6d7f5dde07359afbb352f7237c179

rebased over updated #29719


New commits:

48f70d0update flint to 2.6.0 (alpha version), remove patches
0055c56backport flint compat patch from arb's trunk
7559750skip square-freeness test for polynomials non-fields
d2e055afix and make robust related doctests
1dfd3c2build/pkgs/flint: Add DESTDIR patch
c84f9f1build/pkgs/arb: Bump patch level
add7970build/pkgs/flint: Update to 2.6.1, drop upstreamed patch
7916a33build/pkgs/arb: Update to 2.18.0
387ba00build/pkgs/arb/patches/silence-stderr-exponent-too-large.patch: Remove

comment:30 Changed 2 years ago by git

Commit: 387ba00399b6d7f5dde07359afbb352f7237c179758db64d4d987bfb3efea7b592bb0b492ea58e4b

Branch pushed to git repo; I updated commit sha1. This was a forced push. New commits:

758db64build/pkgs/arb/patches/[flint.. silence-stderr-exponent-too-large].patch: Remove

comment:31 Changed 2 years ago by Dima Pasechnik

it appears to work in Homebrew with XCode 12 on top of Homebrew's Flint 2.6.3.

comment:32 Changed 2 years ago by Dima Pasechnik

2.18.1 is available

comment:33 Changed 2 years ago by git

Commit: 758db64d4d987bfb3efea7b592bb0b492ea58e4b97e0b45fb0e08830cbc3c368e09558f0707e71e7

Branch pushed to git repo; I updated commit sha1. New commits:

97e0b45update to 2.18.1

comment:34 Changed 2 years ago by Dima Pasechnik

Status: newneeds_review
Summary: Upgrade Arb to 2.18.0Upgrade Arb to 2.18.1

comment:35 Changed 2 years ago by Matthias Köppe

Perhaps we need to merge it in 9.2, after all, see #30757

comment:36 Changed 2 years ago by Dima Pasechnik

does it work with Flint version < 2.6, or we need this update too?

comment:37 Changed 2 years ago by Matthias Köppe

I think arb 2.18.x is prepared to work with both old and new flint. But I have not tested it recently.

We should separate this ticket from the flint upgrade

Last edited 2 years ago by Matthias Köppe (previous) (diff)

comment:38 Changed 2 years ago by François Bissey

I am currently using flint-2.5.2 and arb-2.18.1 in Gentoo and it works and doctest fine.

comment:39 Changed 2 years ago by Matthias Köppe

Status: needs_reviewneeds_work
Work issues: rebase away from the flint upgrade ticket

comment:40 Changed 2 years ago by Dima Pasechnik

Dependencies: #29719, #30486#29719, #30486, #30757

I guess the correct base for this should be #30757 - as it adds a patch to arb.

comment:41 Changed 2 years ago by Dima Pasechnik

Branch: u/dimpase/upgrade_arb_to_2_18_0u/dimpase/upgrade_arb_to_2_18_1
Commit: 97e0b45fb0e08830cbc3c368e09558f0707e71e7d6838a115cf59ce8d4070f2bd18c3b9bc2caa5ab
Dependencies: #29719, #30486, #30757

to be tested abit


New commits:

034b594build/pkgs/arb/patches/[flint.. silence-stderr-exponent-too-large].patch: Remove
44302b9update to 2.18.1
d6838a1remove old workaround

comment:42 Changed 2 years ago by Dima Pasechnik

Status: needs_workneeds_review

the new branch works well with Flint 2.5.3 (only tested on Fedora 30 so far)

comment:43 Changed 2 years ago by Dima Pasechnik

Should we also put here the doctest patches from the Flint 2.6.3 update ticket? - this would allow using system Flint 2.6.3

comment:44 Changed 2 years ago by Matthias Köppe

Yes, good idea

comment:45 Changed 2 years ago by Dima Pasechnik

I am testing this, and having a problem: Maxima ghost processes are taking over the machine:

12028 dimpase   20   0  367444 302324  14884 R  42.5   1.8  11:14.59 maxima                                                                                                                                
 7306 dimpase   20   0  491620 426668  15028 R  42.2   2.6  17:44.48 maxima                                                                                                                                
11596 dimpase   20   0  385528 311008  15000 R  41.9   1.9  11:54.40 maxima                                                                                                                                
13577 dimpase   20   0  312752 233244  14956 R  41.9   1.4   7:22.41 maxima                                                                                                                                
14138 dimpase   20   0  296276 231528  14980 R  41.9   1.4   6:21.78 maxima                                                                                                                                
14806 dimpase   20   0  255672 190624  14884 R  41.5   1.2   2:50.26 maxima                                                                                                                                
 8230 dimpase   20   0  490176 425464  14964 R  41.2   2.6  17:20.55 maxima                                                                                                                                
13635 dimpase   20   0  314196 237876  14988 R  40.9   1.5   7:40.07 maxima                                                                                                                                
 6978 dimpase   20   0  490944 426156  15152 R  40.2   2.6  18:02.45 maxima                                                                                                                                
 8635 dimpase   20   0  490852 425820  14960 R  38.9   2.6  16:51.44 maxima                                                                                                                                
15220 dimpase   20   0  255628 190808  14916 R  38.9   1.2   1:58.04 maxima                                                                                                                                
 8050 dimpase   20   0  490176 425796  15296 R  38.5   2.6  17:17.71 maxima                                                                                                                                
15286 dimpase   20   0  238476 173380  14912 R  38.5   1.1   1:21.26 maxima                                                                                                                                
 8678 dimpase   20   0  489920 425044  15036 R  38.2   2.6  16:54.90 maxima                                                                                                                                
14490 dimpase   20   0  295088 230148  14972 R  38.2   1.4   5:27.37 maxima                                                                                                                                
13789 dimpase   20   0  312752 232936  14864 R  37.9   1.4   7:22.27 maxima                                                                                                                                
14116 dimpase   20   0  295600 230720  15040 R  37.2   1.4   6:22.48 maxima                                                                                                                                
14453 dimpase   20   0  296020 231248  14956 R  37.2   1.4   5:27.63 maxima                                                                                                                                
15412 dimpase   20   0  220812 156160  15112 R  36.9   1.0   0:54.24 maxima                                                                                                                                
15971 dimpase   20   0 1418768 244428  43224 R   4.3   1.5   0:00.78 python3                                                                                                                               
15891 dimpase   20   0 1332768 204008  14336 R   3.3   1.2   0:04.51 python3                                                                                                                               
15908 dimpase   20   0 1477908 293144  57444 R   3.3   1.8   0:05.13 python3                                                                                                                               
15937 dimpase   20   0 1672080 289956  26744 R   3.3   1.8   0:03.49 python3                                                                                                                               
15938 dimpase   20   0 1389976 241124  28616 R   3.3   1.5   0:03.50 python3                                                                                                                               
15951 dimpase   20   0 1726520 315200  37664 R   3.3   1.9   0:02.40 python3                                                                                                                               
15953 dimpase   20   0 1333964 220592  30044 R   3.3   1.3   0:02.36 python3                                                                                                                               
15959 dimpase   20   0 1380784 226536  22884 R   3.3   1.4   0:01.63 python3                                                                                                                               
15963 dimpase   20   0 1380456 231188  27976 R   3.3   1.4   0:01.31 python3                                                                                                                               
15976 dimpase   20   0 1338012 213532  18876 R   3.3   1.3   0:00.59 python3                                                                                                                               
15969 dimpase   20   0 1342848 219184  28928 R   3.0   1.3   0:00.86 python3                                                                                                                               
15973 dimpase   20   0 1341560 221264  23480 R   3.0   1.4   0:00.69 python3                 

comment:46 Changed 2 years ago by Dima Pasechnik

This is also a bit weird:

$ find . -name sage-cleaner 
./src/bin/sage-cleaner
./local/bin/sage-cleaner
./build/pkgs/sagelib/src/build/scripts-3.7/sage-cleaner

OK, I'll try a build from scratch.

comment:47 in reply to:  46 Changed 2 years ago by Matthias Köppe

Replying to dimpase:

This is also a bit weird:

$ find . -name sage-cleaner 
./src/bin/sage-cleaner
./local/bin/sage-cleaner
./build/pkgs/sagelib/src/build/scripts-3.7/sage-cleaner

This is normal

comment:48 Changed 2 years ago by Dima Pasechnik

the same picture after make distclean && make -j11 ptest. Half a dozen Maxima processes running for 30 minutes or more. There is a sage-cleaner running (strangely, the one in src/bin, not in local/bin, apparently missing these Maxima zombies.

comment:49 Changed 2 years ago by Dima Pasechnik

$ ps -def | grep sage-clean
dimpase  15068 15000  0 11:33 pts/2    00:00:00 /bin/sh /home/scratch2/dimpase/sage/sage-clang/src/bin/sage-python /home/scratch2/dimpase/sage/sage-clang/src/bin/sage-cleaner
dimpase  15070 15068  0 11:33 pts/2    00:00:00 /home/scratch2/dimpase/sage/sage-clang/local/bin/python3 /home/scratch2/dimpase/sage/sage-clang/src/bin/sage-cleaner
dimpase  27819 22676  0 20:14 pts/14   00:00:00 grep --color=auto sage-clean

why is anything running from src/bin/ at all?

comment:50 Changed 2 years ago by Dima Pasechnik

That's what I have in the patch of ./sage -sh: (or buildsh, no difference)

$ echo $PATH
/home/scratch2/dimpase/sage/sage-clang/build/bin:/home/scratch2/dimpase/sage/sage-clang/src/bin:/home/scratch2/dimpase/sage/sage-clang/local/bin:/home/scratch2/dimpase/miniconda3/condabin:/users/dimpase/perl5/bin:/users/dimpase/bin:/usr/libexec/python3-sphinx:/usr/lib64/qt-3.3/bin:/usr/share/Modules/bin:/usr/lib64/ccache:/usr/local/bin:/usr/bin:/usr/local/sbin:/usr/sbin:/users/dimpase/.cabal/bin:/auto/users/dimpase/bin

comment:51 in reply to:  49 Changed 2 years ago by Matthias Köppe

Replying to dimpase:

$ ps -def | grep sage-clean
dimpase  15068 15000  0 11:33 pts/2    00:00:00 /bin/sh /home/scratch2/dimpase/sage/sage-clang/src/bin/sage-python /home/scratch2/dimpase/sage/sage-clang/src/bin/sage-cleaner
dimpase  15070 15068  0 11:33 pts/2    00:00:00 /home/scratch2/dimpase/sage/sage-clang/local/bin/python3 /home/scratch2/dimpase/sage/sage-clang/src/bin/sage-cleaner
dimpase  27819 22676  0 20:14 pts/14   00:00:00 grep --color=auto sage-clean

why is anything running from src/bin/ at all?

The scripts in $SAGE_SRC/bin are preferred over the installed scripts in $SAGE_LOCAL/bin - see sage-env:

export PATH="$SAGE_ROOT/build/bin:$SAGE_SRC/bin:$SAGE_LOCAL/bin:$PATH"

comment:52 Changed 2 years ago by Dima Pasechnik

that's how it looks some time into make ptest

2901 dimpase   20   0  296788 231908  14816 R  32.6   1.4   6:51.62 maxima                                                          
 3620 dimpase   20   0  271848 206812  14892 R  32.6   1.3   4:43.95 maxima                                                          
14383 dimpase   20   0 1010928 935392  14828 R  32.6   5.7  60:34.33 maxima                                                          
28253 dimpase   20   0  579776 502700  15112 R  32.6   3.1  27:05.16 maxima                                                          
 3993 dimpase   20   0  237584 172452  14872 S  32.2   1.1   2:05.58 maxima                                                          
 9113 dimpase   20   0 1172372   1.0g  14936 R  32.2   6.7  78:25.36 maxima                                                          
  920 dimpase   20   0  366420 301280  14892 R  31.9   1.8  10:21.38 maxima                                                          
 2791 dimpase   20   0  297044 232316  14972 R  31.9   1.4   7:07.70 maxima                                                          
 7627 dimpase   20   0 1207188   1.1g  15220 R  31.9   6.9  81:05.87 maxima                                                          
13239 dimpase   20   0 1082952 984.0m  15912 R  31.9   6.2  69:10.38 maxima                                                          
27668 dimpase   20   0  694396 629220  14808 R  31.9   3.8  31:36.46 maxima                                                          
29342 dimpase   20   0  544960 475212  15076 R  31.9   2.9  24:28.83 maxima                                                          
  764 dimpase   20   0  367444 302668  14964 R  31.6   1.8  11:30.94 maxima                                                          
 2675 dimpase   20   0  296788 232196  15120 R  31.6   1.4   6:50.34 maxima                                                          
 4535 dimpase   20   0  202472 137496  15056 R  31.6   0.8   0:28.07 maxima                                                          
 8979 dimpase   20   0 1153008   1.0g  14772 R  31.6   6.6  76:06.60 maxima                                                          
15549 dimpase   20   0  994964 926360  15244 R  31.6   5.7  59:28.08 maxima                                                          
 3229 dimpase   20   0  296020 231336  15036 R  31.2   1.4   5:44.30 maxima                                                          
 3569 dimpase   20   0  296020 231256  14960 R  31.2   1.4   4:49.63 maxima                                                          
29192 dimpase   20   0  545636 474636  15208 R  31.2   2.9  24:24.71 maxima                                                          
32520 dimpase   20   0  385784 316468  14908 R  31.2   1.9  12:32.67 maxima                                                          
27629 dimpase   20   0  694396 629536  15144 R  30.9   3.8  31:25.58 maxima                                                          
 4458 dimpase   20   0  237288 172552  14992 R  30.6   1.1   1:02.70 maxima                                                          
 4414 dimpase   20   0  237288 172572  14996 R  30.2   1.1   1:02.69 maxima                                                          
 4638 dimpase   20   0 1517256 299848  58604 R   2.7   1.8   0:03.71 python3                                                         
 4654 dimpase   20   0 1511288 293552  50604 R   2.3   1.8   0:03.54 python3                                                         
 4882 dimpase   20   0 1335900 202072  12196 R   2.3   1.2   0:00.63 python3                                                         
 5156 dimpase   20   0   14652   9852   5216 R   2.3   0.1   0:00.08 python3                                                         
 4679 dimpase   20   0 1473088 303752  70860 R   2.0   1.9   0:03.21 python3                                                         
 4714 dimpase   20   0 1362904 251744  39536 R   2.0   1.5   0:02.18 python3                                                         

Any idea as to what causes sage-cleaner to leave these maxima processes running? E.g. here is one long-running one:

01:21:52 /home/scratch2/dimpase/sage/sage-clang/local/lib/maxima/5.44.0/binary-ecl/maxima --frame-stack 4096 --lisp-stack 65536 -- -p /home/scratch2/dimpase/sage/sage-clang/local/lib64/python3.7/site-packages/sage/interfaces/sage-maxima.lisp

This is Fedora 30, and so ECL is built with system (threaded) libgc version 7.6.4 and libatomic_ops, if it matters, don't know.

comment:53 Changed 2 years ago by Matthias Köppe

Branch: u/dimpase/upgrade_arb_to_2_18_1u/mkoeppe/upgrade_arb_to_2_18_1

comment:54 Changed 2 years ago by Matthias Köppe

Authors: Matthias Koeppe, ...Matthias Koeppe, Dima Pasechnik
Branch: u/mkoeppe/upgrade_arb_to_2_18_1u/dimpase/upgrade_arb_to_2_18_1
Reviewers: Dima PasechnikDima Pasechnik, ...
Work issues: rebase away from the flint upgrade ticket

comment:55 Changed 2 years ago by Matthias Köppe

Branch: u/dimpase/upgrade_arb_to_2_18_1u/mkoeppe/upgrade_arb_to_2_18_1

comment:56 Changed 2 years ago by Dima Pasechnik

Commit: d6838a115cf59ce8d4070f2bd18c3b9bc2caa5ab9515c6d543c12a16ae2dcdcf0dd5d2676d38d3f5
Reviewers: Dima Pasechnik, ...Dima Pasechnik
Status: needs_reviewpositive_review

it all works just fine.


New commits:

0a99383build/pkgs/arb/patches/[flint.. silence-stderr-exponent-too-large].patch: Remove
e4005b1update to 2.18.1
9515c6dremove old workaround

comment:57 Changed 2 years ago by Volker Braun

Status: positive_reviewneeds_work

On 32-bit:

**********************************************************************
File "src/sage/rings/real_arb.pyx", line 300, in sage.rings.real_arb.arb_to_mpfi
Failed example:
    RIF(RBF(2)**(2**100)) # arb218 # indirect doctest
Expected:
    [5.8756537891115869e1388255822130839282 .. +infinity]
Got:
    [2.0985787164673874e323228496 .. +infinity]
**********************************************************************
1 item had failures:
   1 of   2 in sage.rings.real_arb.arb_to_mpfi
    [546 tests, 1 failure, 0.37 s]
----------------------------------------------------------------------
sage -t --long --random-seed=0 src/sage/rings/real_arb.pyx  # 1 doctest failed
----------------------------------------------------------------------

comment:58 Changed 2 years ago by Dima Pasechnik

Branch: u/mkoeppe/upgrade_arb_to_2_18_1u/dimpase/upgrade_arb_to_2_18_1
Commit: 9515c6d543c12a16ae2dcdcf0dd5d2676d38d3f50ce02a265480cbef1289d6fb877d6530ef26f741
Status: needs_workneeds_review

New commits:

62fee73build/pkgs/arb/patches/[flint.. silence-stderr-exponent-too-large].patch: Remove
bf63df7update to 2.18.1
1120656remove old workaround
0ce02a2add 64/32-bit tags and results

comment:59 Changed 2 years ago by Dima Pasechnik

rebased over the latest beta and added tags. Please test on 32 bits in particular

comment:60 Changed 2 years ago by git

Commit: 0ce02a265480cbef1289d6fb877d6530ef26f7414e5e12d183234193eb4a2f667ce5916bf8a1fe76

Branch pushed to git repo; I updated commit sha1. New commits:

4e5e12dadd missing dots

comment:61 Changed 2 years ago by Dima Pasechnik

passes all the tests on 32-bit now

comment:62 Changed 2 years ago by git

Commit: 4e5e12d183234193eb4a2f667ce5916bf8a1fe760c9c4ed35c2eaf34ae0d19387c07b7f460e4abce

Branch pushed to git repo; I updated commit sha1. This was a forced push. New commits:

0c9c4edcorrect the tags placement, add dots

comment:63 Changed 2 years ago by Dima Pasechnik

duh, now it's finally right, passes both on 32 and 64 bits.

comment:64 Changed 2 years ago by Matthias Köppe

Reviewers: Dima PasechnikDima Pasechnik, Matthias Koeppe
Status: needs_reviewpositive_review

LGTM

comment:65 Changed 2 years ago by Volker Braun

Branch: u/dimpase/upgrade_arb_to_2_18_10c9c4ed35c2eaf34ae0d19387c07b7f460e4abce
Resolution: fixed
Status: positive_reviewclosed
Note: See TracTickets for help on using tickets.