Opened 2 years ago

Closed 3 months ago

#28553 closed defect (fixed)

libsemigroups does not pass self-tests on 32bit system

Reported by: tmonteil Owned by:
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: packages: optional Keywords: sdl
Cc: dimpase, nthiery, isuruf, tscrim, slelievre Merged in:
Authors: Reviewers: Matthias Koeppe
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description (last modified by tmonteil)

Recently added libsemigroups (#27396) does not pass self-tests on 32bit system, see the attached log.

Attachments (1)

libsemigroups-0.6.7.log (38.2 KB) - added by tmonteil 2 years ago.

Download all attachments as: .zip

Change History (9)

Changed 2 years ago by tmonteil

comment:1 Changed 2 years ago by tmonteil

  • Cc dimpase nthiery isuruf tscrim added
  • Description modified (diff)

comment:2 Changed 21 months ago by embray

  • Milestone changed from sage-9.0 to sage-9.1

Ticket retargeted after milestone closed

comment:3 Changed 17 months ago by mkoeppe

  • Milestone changed from sage-9.1 to sage-9.2

comment:4 Changed 11 months ago by mkoeppe

  • Milestone changed from sage-9.2 to sage-9.3

comment:5 Changed 9 months ago by slelievre

  • Cc slelievre added
  • Milestone changed from sage-9.3 to sage-duplicate/invalid/wontfix
  • Status changed from new to needs_review

This may have been fixed in libsemigroups 1.0.3:

comment:6 Changed 9 months ago by tscrim

Can someone with a 32-bit system please confirm?

comment:7 Changed 9 months ago by mkoeppe

  • Reviewers set to Matthias Koeppe
  • Status changed from needs_review to positive_review

GH Actions tests a few 32-bit systems.

On ubuntu-bionic-i386 (https://github.com/sagemath/sage/runs/1615246784?check_suite_focus=true), libsemigroups is OK.

On centos-7-i386 (https://github.com/sagemath/sage/runs/1615246935?check_suite_focus=true), compilation of libsemigroups fails, but this is the same error as on 64 bit centos-7 (https://github.com/sagemath/sage/runs/1615246513?check_suite_focus=true) and is caused by an outdated compiler.

comment:8 Changed 3 months ago by slelievre

  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.