Opened 20 months ago

Closed 20 months ago

Last modified 19 months ago

#28433 closed enhancement (duplicate)

Degenerate Metric Manifold

Reported by: Dicolevrai Owned by:
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: geometry Keywords: Degenerate (or lightlike) submanifold
Cc: Merged in:
Authors: Hans Fotsing Tetsing Reviewers:
Report Upstream: N/A Work issues:
Branch: public/manifolds/DegenerateMetricManifold (Commits, GitHub, GitLab) Commit: 089b2103a5c951707a890fa10d66d2d147014b88
Dependencies: Stopgaps:

Status badges

Description

An *embedded (resp. immersed) degenerate submanifold of a proper pseudo-Riemannian manifold* (M,g) is an embedded (resp. immersed) submanifold H of M as a differentiable manifold such that pull back of the metric tensor g via the embedding (resp. immersion) endows H with the structure of a degenerate manifold.

Degenerate submanifolds are study in many fields of mathematics and physics, for instance in Differential Geometry (especially in geometry of lightlike submanifold) and in General Relativity. In geometry of lightlike submanifolds, according to the dimension r of the radical distribution (see below for definition of radical distribution), degenerate submanifolds have been classify into 4 subgroups: r-lightlike submanifolds, Coisotropic submanifolds, Isotropic submanifolds and Totally lightlike submanifolds. (See the book of Krishan L. Duggal and Aurel Bejancu in *REFERENCES*.)

In the present module, you can definie any of the 4 types but most of the methods are implemented only for degenerate hypersurfaces who belong to r-lightlike submanifolds. However, their might be generalized to 1-lightlike submanifolds. In the litterature there is a new approach (the rigging technique) for studying 1-lightlike submanifolds but here we we the method of Krishan L. Duggal and Aurel Bejancu base on the screen distribution.

Let H be a lightlike hypersurface of a pseudo-Riemannian manifold (M,g). Then the normal bundle T^\perp H intersect the tangent bundle TH. The radical distribution is defined as 'Rad(TH)=TH\cap T\perp H'. In case of hypersurfaces, and more generally 1-lightlike submanifolds, this is a rank 1 distribution. A screen distribution S(TH) is a complementary of Rad(TH) in TH.

Giving a screen distribution S(TH) and a null vector field \xi locally defined and spanning Rad(TH), there exists a unique transversal null vector field 'N' locally defined and such that g(N,\xi)=1. From a transverse vector 'v', the null rigging 'N' is giving by the formula

.. MATH::

N = \frac{1}{g(\xi, v)}\left(v-\frac{g(v,v)}{2g(xi, v)}\xi\right)

Tensors on the ambient manifold 'M' are projected on 'H' along 'N' to obtain induced objects. For instance, induced connection is the linear connexion defined on H through the Levi-Civitta connection of 'g' along N.

To work on a degenerate submanifold, after defining H as an instance of :class:~sage.manifolds.differentiable.manifold.DifferentiableManifold, with the keyword *structure='degenerate'*, you have to set a transvervector v and screen distribution together with the radical distribution.

An example of degenerate submanifold from General Relativity is the horizon of the Shawrzschild black hole. Allow us to recall that Shawrzschild black hole is the first non-trivial solution of Einstein's equations. It describes the metric inside a star of radius R = 2m, being m the inertial mass of the star. It can be seen as an open ball in a Lorentzian manifold structure on \RR^4::

Change History (4)

comment:1 Changed 20 months ago by chapoton

duplicate of #26355 ?

comment:2 Changed 20 months ago by Dicolevrai

Yes, this is a duplicate of #26355

comment:3 Changed 20 months ago by chapoton

  • Milestone changed from sage-8.9 to sage-duplicate/invalid/wontfix
  • Resolution set to duplicate
  • Status changed from new to closed

Then you should have set the milestone to duplicate/invalid/wontfix. I did it for you, and then closed the ticket.

comment:4 Changed 19 months ago by slelievre

  • Component changed from PLEASE CHANGE to geometry
  • Type changed from PLEASE CHANGE to enhancement
Note: See TracTickets for help on using tickets.