Opened 4 months ago

Closed 4 months ago

#28232 closed defect (fixed)

py3: fix doctests in doctest/test

Reported by: gh-mwageringel Owned by:
Priority: minor Milestone: sage-8.9
Component: python3 Keywords:
Cc: Merged in:
Authors: Markus Wageringel Reviewers: John Palmieri
Report Upstream: N/A Work issues:
Branch: 4be8c5d (Commits) Commit: 4be8c5ddb39cc3f49ece3c2181a9c23649c002ea
Dependencies: Stopgaps:

Description

This ticket fixes the last Python 3 doctest failure in doctest/test.py.

The problem is that the doctest dispatcher relies on internals of the multiprocessing library, which slightly changed in Python 3; see the relevant file. Because of that, until now with Python 3, the master doctest process waits for its children to exit before exiting itself, even though it is not supposed to.

I also adjusted the affected doctest so that it checks for what was initially intended. This got lost when the minimum die_timeout of subprocesses got increased from 20 to 60 seconds, but this also means the doctest now lasts 40 seconds longer than before.

Change History (3)

comment:1 Changed 4 months ago by gh-mwageringel

  • Authors set to Markus Wageringel
  • Branch set to u/gh-mwageringel/28232
  • Commit set to 4be8c5ddb39cc3f49ece3c2181a9c23649c002ea
  • Status changed from new to needs_review

New commits:

4be8c5d28232: py3: do not wait for subprocesses on exit

comment:2 Changed 4 months ago by jhpalmieri

  • Reviewers set to John Palmieri
  • Status changed from needs_review to positive_review

Nice work. Looks good to me.

comment:3 Changed 4 months ago by vbraun

  • Branch changed from u/gh-mwageringel/28232 to 4be8c5ddb39cc3f49ece3c2181a9c23649c002ea
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.