Opened 13 years ago

Closed 5 years ago

#2817 closed enhancement (duplicate)

specify options for parts of graphs

Reported by: jason Owned by: jason
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: graph theory Keywords:
Cc: ncohen Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

See the post at:

http://groups.google.com/group/sage-support/browse_thread/thread/64b76550609c1019

One way to handle setting display options for different vertices/edges is to have the following conventions:

  • If edge_style is the dictionary edge_style, pass edge_style into the arrow() commands
  • If edge_style is a list, then we want to create (possibly different) edge_style dictionaries for each edge. For each item in the list:
    • if the item is a dictionary d, then update all edge_style dictionaries with the dictionary d.
    • if the item is a list L with L[0]=list of edges, L[1]=dictionary d, then for each edge in L[0], update its edge_style with d.

Optimize this so that we create a dictionary for an edge iff it has a different edge style than other edges. In other words, first have only one edge_style dictionary. If a list is edges is then specified, then take those out of the default edge_list and update their dictionary, etc. is there a data structure which efficiently partitions objects (maybe Sage partitions!?)

Change History (6)

comment:1 Changed 13 years ago by rlm

  • Owner changed from rlm to jason

comment:2 Changed 13 years ago by jason

  • Milestone changed from sage-3.1.3 to sage-wishlist

comment:3 Changed 5 years ago by jmantysalo

  • Cc ncohen added
  • Milestone changed from sage-wishlist to sage-duplicate/invalid/wontfix
  • Report Upstream set to N/A
  • Status changed from new to needs_review

Nathann, I think this is a duplicate of #13827. If you agree, please put on positive_review.

comment:4 follow-up: Changed 5 years ago by ncohen

Do you consider #13827 as a ticket which aims at making all options of Graph.plot able to take [edge/vertex]-specific instructions? If so, could you update its description before setting this one to positive_review? Right now all the description of #13827 says is that it should be possible to provide an alternative text to the vertices' name.

Nathann

comment:5 in reply to: ↑ 4 Changed 5 years ago by jmantysalo

  • Status changed from needs_review to positive_review

Replying to ncohen:

Do you consider #13827 as a ticket which aims at making all options of Graph.plot able to take [edge/vertex]-specific instructions? If so, could you update its description before setting this one to positive_review? Right now all the description of #13827 says is that it should be possible to provide an alternative text to the vertices' name.

Done that.

(For now that ticket is kind of waiting for someone to decide if my suggestions are good or not. ​Punarbasu Purkayastha suggested other kind of interface.)

comment:6 Changed 5 years ago by vbraun

  • Resolution set to duplicate
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.