Opened 4 months ago

Closed 4 months ago

#28151 closed enhancement (fixed)

Upgrade R to 3.6.1

Reported by: charpent Owned by:
Priority: major Milestone: sage-8.9
Component: packages: standard Keywords: r-project
Cc: dimpase, embray, slelievre, arojas, infinity0 Merged in:
Authors: Emmanuel Charpentier Reviewers: Dima Pasechnik
Report Upstream: N/A Work issues:
Branch: b028edf (Commits) Commit: b028edfe27a9d7808f3132fee52558aeef87f4e9
Dependencies: Stopgaps:

Description

R 3.6.1 is out. And the usual reasons push towards pulling it in Sage...

The upstream tarball is here : http://cran.r-project.org/src/base/R-3/R-3.6.1.tar.gz

Change History (6)

comment:1 Changed 4 months ago by charpent

  • Cc dimpase embray slelievre arojas infinity0 added
  • Component changed from PLEASE CHANGE to packages: standard
  • Keywords r-project added
  • Type changed from PLEASE CHANGE to enhancement

comment:2 Changed 4 months ago by charpent

  • Branch set to u/charpent/upgrade_r_to_3_6_1

comment:3 Changed 4 months ago by charpent

  • Authors set to Emmanuel Charpentier
  • Commit set to b028edfe27a9d7808f3132fee52558aeef87f4e9
  • Status changed from new to needs_review

On 8.9.beta2 compiled with Python2 : builds and passes ptestlong with no error whatsoever.

==> needs_review

With Python 3 : see the romancero on sage-devel


New commits:

b028edfR 3.6.1 : drop new tarball, fix checksum.

comment:4 Changed 4 months ago by charpent

After a waltz around the git trac problem, make ptest-python3 gets exactly the same results with the present patch as with R 3.6.0.

===> still needs_review...

comment:5 Changed 4 months ago by dimpase

  • Reviewers set to Dima Pasechnik
  • Status changed from needs_review to positive_review

LGTM, over to bots.

comment:6 Changed 4 months ago by vbraun

  • Branch changed from u/charpent/upgrade_r_to_3_6_1 to b028edfe27a9d7808f3132fee52558aeef87f4e9
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.