Opened 9 years ago

Closed 9 years ago

Last modified 2 years ago

#2809 closed defect (duplicate)

G2 fundamental weights were the negative of what they should be.

Reported by: bump Owned by: mhansen
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: combinatorics Keywords:
Cc: sage-combinat Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description (last modified by chapoton)

In combinat/root_system.py, the fundamental weights for the various root systems are entered by hand. For G2, the fundamental weights were the negatives of what they should be.

diff -r 80b506b8e07c sage/combinat/root_system.py
--- a/sage/combinat/root_system.py Tue Apr 01 19:18:55 2008 -0700
+++ b/sage/combinat/root_system.py Sat Apr 05 08:40:46 2008 -0700
@@ -788,11 +788,11 @@ class AmbientLattice_g(AmbientLattice_ge
         """
         EXAMPLES:
             sage: CartanType(['G',2]).root_system().ambient_lattice().fundamental_weights()
-            [(-1, 0, 1), (-2, 1, 1)]
+            [(1, 0, -1), (2, -1, -1)]
         """
         return [ c0*self._term(0)+c1*self._term(1)+c2*self._term(2) \
                  for [c0,c1,c2] in
-                 [[-1,0,1],[-2,1,1]]]
+                 [[1,0,-1],[2,-1,-1]]]
 
 
 def WeylDim(type, coeffs):

Attachments (1)

g2.patch (777 bytes) - added by bump 9 years ago.

Download all attachments as: .zip

Change History (4)

Changed 9 years ago by bump

comment:1 Changed 9 years ago by mabshoff

  • Milestone changed from sage-3.0 to sage-duplicate/invalid
  • Resolution set to duplicate
  • Status changed from new to closed

This is a dupe of #2808, so I am closing it. Dan: once you open a ticket and you hit "submit" you should remove the "preview" bit from the url before going on. This is a buglet in trac and you aren't the first one who has been bitten by it.

Cheers,

Michael

comment:2 Changed 8 years ago by nthiery

  • Cc sage-combinat added

comment:3 Changed 2 years ago by chapoton

  • Description modified (diff)
  • Report Upstream set to N/A
Note: See TracTickets for help on using tickets.