#28013 closed enhancement (duplicate)

Build Python 3 docker images

Reported by: saraedum Owned by:
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: distribution Keywords: days101, py3, docker
Cc: vdelecroix Merged in:
Authors: Reviewers: Julian Rüth
Report Upstream: N/A Work issues:
Branch: public/t-28013-py3-docker-images (Commits, GitHub, GitLab) Commit: 054a0b49b5afe81bff92a7ef6840de086bda017c
Dependencies: Stopgaps:

Status badges

Description


Change History (13)

comment:1 Changed 22 months ago by saraedum

  • Status changed from new to needs_info

comment:2 Changed 22 months ago by saraedum

  • Status changed from needs_info to needs_work

Currently, this is a hack to see whether building on Docker works. We should of course build both Py2 and Py3.

comment:3 Changed 22 months ago by slelievre

  • Keywords days101 py3 docker added

comment:4 Changed 22 months ago by slelievre

  • Branch set to u/slelievre/t-28013-py3-docker-images

comment:5 Changed 22 months ago by saraedum

  • Commit set to b96f62ff11bc7eae875ff542ee55716cf2870766

You can see the status of this at: https://gitlab.com/sagemath/dev/trac/commits/u/slelievre/t-28013-py3-docker-images


New commits:

b96f62f#28013 py3 docker images

comment:6 Changed 22 months ago by saraedum

  • Branch changed from u/slelievre/t-28013-py3-docker-images to u/saraedum/t-28013-py3-docker-images

comment:7 Changed 22 months ago by embray

  • Commit changed from b96f62ff11bc7eae875ff542ee55716cf2870766 to 0d8d4c18ddcfbab5959bfd77069cdded142d96eb

Currently it looks like my gitlab runners are working, but every ticket build is timing out because for some reason they're all trying to build openblas, and then timing out after 3 hours.

The openblas update is new as of I think 8.8.rc0 (I think it was maybe a mistake to update as big a package as openblas in a release candidate). The docker build of 8.8.rc0 seems to have failed in the test-dev job for some random reason. So I'll try re-running it... Then all the 8.8.rc1 builds failed as well for some non-obvious reason.


New commits:

0d8d4c1Fix gitlab-ci.yml

comment:8 follow-up: Changed 22 months ago by embray

Which is also strange because there does appear to be an 8.8.rc1 image tagged on sagemath/sagemath-dev even though the "Release" stage didn't run...?

comment:9 in reply to: ↑ 8 Changed 22 months ago by embray

Replying to embray:

Which is also strange because there does appear to be an 8.8.rc1 image tagged on sagemath/sagemath-dev even though the "Release" stage didn't run...?

Oh, I see, building/releasing from the 8.8.rc1 tag did pass, but from the develop branch did not pass.

I guess then maybe many of the trac tickets are not based off 8.8.rc1 yet so they're still pulling docker images of older builds that don't include the openblas update.

comment:10 Changed 22 months ago by slelievre

  • Branch changed from u/saraedum/t-28013-py3-docker-images to public/t-28013-py3-docker-images
  • Commit changed from 0d8d4c18ddcfbab5959bfd77069cdded142d96eb to 054a0b49b5afe81bff92a7ef6840de086bda017c

Let's use a public branch for this.


New commits:

054a0b4Update branch name in .gitlab-ci.yml

comment:11 Changed 20 months ago by saraedum

  • Milestone changed from sage-8.9 to sage-duplicate/invalid/wontfix
  • Status changed from needs_work to positive_review

Duplicate of #28041.

comment:12 Changed 20 months ago by slelievre

  • Authors Samuel Lelièvre deleted

Ok.

comment:13 Changed 20 months ago by chapoton

  • Resolution set to duplicate
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.