Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#28001 closed enhancement (fixed)

Rename BooleanFunction.absolut_indicator to .absolute_indicator

Reported by: Friedrich Wiemer Owned by:
Priority: major Milestone: sage-8.9
Component: cryptography Keywords: BooleanFunction
Cc: Merged in:
Authors: Friedrich Wiemer Reviewers: Frédéric Chapoton
Report Upstream: N/A Work issues:
Branch: 01addb0 (Commits, GitHub, GitLab) Commit: 01addb0527a8859653c1b5a9455d3818952eafe2
Dependencies: Stopgaps:

Status badges

Description

The BooleanFunction method .absolut_indicator should be named .absolute_indicator.

Change History (18)

comment:1 Changed 3 years ago by Friedrich Wiemer

Branch: u/asante/rename_booleanfunction_absolut_indicator_to__absolute_indicator

comment:2 Changed 3 years ago by Friedrich Wiemer

Commit: 8df690fd2a4e7a0c36e7dbc05c22d4d977217065
Status: newneeds_review

comment:3 Changed 3 years ago by git

Commit: 8df690fd2a4e7a0c36e7dbc05c22d4d97721706521c66c0d2fa8eebc30bb873da38ad3db654720e3

Branch pushed to git repo; I updated commit sha1. New commits:

21c66c0renamed absolute indicator

comment:4 Changed 3 years ago by Frédéric Chapoton

Fix the doc too.

"""Return the absolut indicator of the function. Ths is the maximal absolut"""

comment:5 Changed 3 years ago by git

Commit: 21c66c0d2fa8eebc30bb873da38ad3db654720e37d75ea3301d56cdca8c35e7120d6136a102a2535

Branch pushed to git repo; I updated commit sha1. New commits:

7d75ea3fix typo in docstring, too

comment:6 Changed 3 years ago by Friedrich Wiemer

Good catch, thanks!

comment:7 Changed 3 years ago by Frédéric Chapoton

The deprecated name should be doctested..

comment:8 Changed 3 years ago by Frédéric Chapoton

Status: needs_reviewneeds_work

comment:9 Changed 3 years ago by git

Commit: 7d75ea3301d56cdca8c35e7120d6136a102a253501addb0527a8859653c1b5a9455d3818952eafe2

Branch pushed to git repo; I updated commit sha1. New commits:

01addb0doctest deprecated method

comment:10 Changed 3 years ago by Friedrich Wiemer

Oh, I'm sorry I did not knew that. How should the doctest be, like the one pushed?

comment:11 Changed 3 years ago by Frédéric Chapoton

No problem.

Just add a TESTS:: section in the new-named method, with a doctest calling the deprecated name.

comment:12 Changed 3 years ago by Frédéric Chapoton

ok, it's good as it is

comment:13 Changed 3 years ago by Frédéric Chapoton

Reviewers: Frédéric Chapoton
Status: needs_workpositive_review

comment:14 Changed 3 years ago by Friedrich Wiemer

OK I think the TESTS:: variant is nicer, I'll change it accordingly.

comment:15 Changed 3 years ago by Frédéric Chapoton

Hmm, it is generally not recommended to make changes after positive review, unless there is a very good reason..

comment:16 Changed 3 years ago by Friedrich Wiemer

OK than we'll keep it like this.

comment:17 Changed 3 years ago by Volker Braun

Branch: u/asante/rename_booleanfunction_absolut_indicator_to__absolute_indicator01addb0527a8859653c1b5a9455d3818952eafe2
Resolution: fixed
Status: positive_reviewclosed

comment:18 Changed 3 years ago by Erik Bray

Milestone: sage-8.8sage-8.9

Not in Sage 8.8. Let's please to try keep tickets' milestones related to the release in which we actually intend to include them, and in particular the release in which they were actually included, especially when closing tickets.

Note: See TracTickets for help on using tickets.