Opened 3 years ago

Closed 3 years ago

#27801 closed enhancement (fixed)

spkg-configure.m4 for ninja-build

Reported by: dimpase Owned by:
Priority: major Milestone: sage-8.8
Component: build: configure Keywords:
Cc: mkoeppe, embray Merged in:
Authors: Dima Pasechnik Reviewers: Matthias Koeppe
Report Upstream: N/A Work issues:
Branch: 0b96a6e (Commits, GitHub, GitLab) Commit: 0b96a6e373576962643703554837853921dfffd1
Dependencies: Stopgaps:

Status badges

Description

a trivial check for the version of the executable ninja.

Change History (5)

comment:1 Changed 3 years ago by dimpase

  • Authors set to Dima Pasechnik
  • Branch set to u/dimpase/packages/ninja_build-config
  • Commit set to 0b96a6e373576962643703554837853921dfffd1

New commits:

0b96a6espkg-configure for ninja_build, checking for version 1.7.2 or better

comment:2 Changed 3 years ago by dimpase

  • Cc mkoeppe embray added
  • Status changed from new to needs_review

this is used to build polymake, but it's normally available on systems. The minimum version is set to match the one in stable Debian. How about Cygwin and OSX?

comment:3 Changed 3 years ago by mkoeppe

For macOS, it's available on homebrew as package ninja.

comment:4 Changed 3 years ago by mkoeppe

  • Reviewers set to Matthias Koeppe
  • Status changed from needs_review to positive_review

comment:5 Changed 3 years ago by vbraun

  • Branch changed from u/dimpase/packages/ninja_build-config to 0b96a6e373576962643703554837853921dfffd1
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.