Opened 9 months ago

Closed 9 months ago

#27589 closed defect (duplicate)

uninstall.py should always remove symbolic links

Reported by: dimpase Owned by:
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: build Keywords:
Cc: embray, jhpalmieri Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description

On OSX 10.14 I see a weird behaviour of uninstall.py: sometimes it leaves symbolic links to libraries unremoved, and then the re-install of a package fails, as these links cannot be overwritten.

I gather this might be due to os.path.exists() returning False on existing, but broken, symbolic links (and they can become broken if files they point to are removed first).

I am experimenting with os.path.exists() or os.path.lexists() test for existence in build/sage_bootstrap/uninstall.py - this should return True on broken links too.

Change History (5)

comment:1 Changed 9 months ago by jhpalmieri

Is this a duplicate of #27544?

comment:2 Changed 9 months ago by dimpase

it is. Somehow I ended up on a branch without that ticket...

comment:3 Changed 9 months ago by jhpalmieri

  • Milestone changed from sage-8.8 to sage-duplicate/invalid/wontfix
  • Status changed from new to needs_review

comment:4 Changed 9 months ago by jhpalmieri

  • Status changed from needs_review to positive_review

comment:5 Changed 9 months ago by embray

  • Resolution set to duplicate
  • Status changed from positive_review to closed

It was only merged by Volker 4 days ago so it's not too surprising you missed it. At least this adds further confirmation of the issue and its solution.

Note: See TracTickets for help on using tickets.