Opened 9 months ago

Closed 8 months ago

#27519 closed enhancement (fixed)

Update `src/ext/doctest/python3-known-passing.txt`

Reported by: jhpalmieri Owned by:
Priority: critical Milestone: sage-8.8
Component: python3 Keywords:
Cc: Merged in:
Authors: John Palmieri Reviewers: Jeroen Demeyer
Report Upstream: N/A Work issues:
Branch: fb4381f (Commits) Commit: fb4381f6f22aad010e151970fb8c285d2781b2b8
Dependencies: #25680 Stopgaps:

Description

Update the list of files whose doctests should pass with Python 3.

Change History (10)

comment:1 Changed 9 months ago by jhpalmieri

  • Branch set to u/jhpalmieri/update-known-py3-tests

comment:2 Changed 9 months ago by jhpalmieri

  • Commit set to 930556ef2431797de5c76d0bd9cc26251a18b7e9

I'm also tempted to make this change:

  • Makefile

    diff --git a/Makefile b/Makefile
    index cb1e291313..7628ad7855 100644
    a b fast-rebuild-clean: misc-clean bdist-clean 
    143143
    144144TESTALL = ./sage -t --all
    145145PTESTALL = ./sage -t -p --all
    146 PTEST_PYTHON3 = cat src/ext/doctest/python3-known-passing.txt | xargs ./sage -t --long -p
     146PTEST_PYTHON3 = sed '/^\#.*$$/d' src/ext/doctest/python3-known-passing.txt | xargs ./sage -t --long -p
    147147
    148148# Flags for ./sage -t --all.
    149149# By default, include all tests marked 'dochtml' -- see
  • src/ext/doctest/python3-known-passing.txt

    diff --git a/src/ext/doctest/python3-known-passing.txt b/src/ext/doctest/python3-known-passing.txt
    index 0b70f229f0..99412b844e 100644
    a b  
     1# Each line starting with '#' is a comment.
     2# Each other line should list a directory in which doctests are known
     3# to pass with Python 3.
     4#
    15src/sage/algebras/
    26src/sage/arith/
    37src/sage/calculus/

Comments? Good idea or bad? Here or on another ticket?


New commits:

930556etrac 27519: update python3-known-passing.txt

comment:3 Changed 9 months ago by git

  • Commit changed from 930556ef2431797de5c76d0bd9cc26251a18b7e9 to fb4381f6f22aad010e151970fb8c285d2781b2b8

Branch pushed to git repo; I updated commit sha1. This was a forced push. New commits:

fb4381ftrac 27519: update python3-known-passing.txt

comment:4 Changed 9 months ago by jhpalmieri

  • Status changed from new to needs_review

comment:5 Changed 9 months ago by jdemeyer

I would really like to focus our Python3 effort on Python 3.7 (#25680) first.

If it weren't for the previous ticket updating python3-known-passing.txt, #25680 would have been merged already. At some point, everything worked with 3.7 but because the tests are such a moving target, stuff got broken again.

For that reason, I'm personally -1 on this ticket.

comment:6 follow-up: Changed 9 months ago by jhpalmieri

The file hasn't been modified in a month, and it is important to try to catch regressions. I think upgrading once per release is not too often. Did you never want to modify this file? What's your alternative?

What is left to be done on #25680, anyway?

comment:7 in reply to: ↑ 6 Changed 9 months ago by jdemeyer

Replying to jhpalmieri:

Did you never want to modify this file? What's your alternative?

My suggestion is to first merge #25680.

comment:8 Changed 9 months ago by jdemeyer

  • Component changed from PLEASE CHANGE to python3
  • Dependencies set to #25680

comment:9 Changed 9 months ago by jdemeyer

  • Milestone changed from sage-8.7 to sage-8.8
  • Reviewers set to Jeroen Demeyer
  • Status changed from needs_review to positive_review

comment:10 Changed 8 months ago by vbraun

  • Branch changed from u/jhpalmieri/update-known-py3-tests to fb4381f6f22aad010e151970fb8c285d2781b2b8
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.