Opened 10 months ago

Closed 7 months ago

Last modified 7 months ago

#27514 closed defect (fixed)

Cygwin docbuild fails

Reported by: vbraun Owned by:
Priority: major Milestone: sage-8.9
Component: build Keywords:
Cc: embray, jdemeyer Merged in:
Authors: Erik Bray Reviewers: Volker Braun
Report Upstream: N/A Work issues:
Branch: a7d28a1 (Commits) Commit: a7d28a1ee61c46b1335cb46c7a3cf52c9d56a952
Dependencies: Stopgaps:

Description

This is on the cygwin buildbot:

**********************************************************************
File "src/sage_setup/docbuild/__init__.py", line 105, in sage_setup.docbuild.builder_helper
Failed example:
    build_many(build_ref_doc, [("docname", "en", "html", {})])
Expected:
    Traceback (most recent call last):
    ...
    Exception: ('Non-exception during docbuild: abort pool operation', BaseException('abort pool operation',))
Got:
    Process Process-3733:1:
    Traceback (most recent call last):
      File "/home/Admin/sage-buildbot-worker/sage_git/build/local/lib/python2.7/multiprocessing/process.py", line 267, in _bootstrap
        self.run()
      File "/home/Admin/sage-buildbot-worker/sage_git/build/local/lib/python2.7/multiprocessing/process.py", line 114, in run
        self._target(*self._args, **self._kwargs)
      File "/home/Admin/sage-buildbot-worker/sage_git/build/local/lib/python2.7/site-packages/sage_setup/docbuild/__init__.py", line 80, in build_ref_doc
        getattr(ReferenceSubBuilder(doc, lang), format)(*args, **kwds)
      File "/home/Admin/sage-buildbot-worker/sage_git/build/local/lib/python2.7/site-packages/sage_setup/docbuild/__init__.py", line 763, in _wrapper
        getattr(DocBuilder, build_type)(self, *args, **kwds)
      File "/home/Admin/sage-buildbot-worker/sage_git/build/local/lib/python2.7/site-packages/sage_setup/docbuild/__init__.py", line 145, in f
        raise Exception("Non-exception during docbuild: %s"%(e,), e)
    Exception: ('Non-exception during docbuild: abort pool operation', BaseException('abort pool operation',))
    Traceback (most recent call last):
      File "/home/Admin/sage-buildbot-worker/sage_git/build/local/lib/python2.7/site-packages/sage/doctest/forker.py", line 671, in _run
        self.compile_and_execute(example, compiler, test.globs)
      File "/home/Admin/sage-buildbot-worker/sage_git/build/local/lib/python2.7/site-packages/sage/doctest/forker.py", line 1095, in compile_and_execute
        exec(compiled, globs)
      File "<doctest sage_setup.docbuild.builder_helper[7]>", line 1, in <module>
        build_many(build_ref_doc, [("docname", "en", "html", {})])
      File "/home/Admin/sage-buildbot-worker/sage_git/build/local/lib/python2.7/site-packages/sage_setup/docbuild/utils.py", line 214, in _build_many
        raise worker_exc
    WorkerDiedException: worker for ('docname', 'en', 'html', {}) died with non-zero exit code 1
**********************************************************************
1 item had failures:
   1 of  10 in sage_setup.docbuild.builder_helper
    [36 tests, 1 failure, 2.33 s]
----------------------------------------------------------------------

Change History (7)

comment:1 Changed 10 months ago by embray

  • Cc jdemeyer added

I'm not sure what to even do about this test since it's not applicable to the new build_many code. This test is a regression test for behavior specific to multiprocessing.Pool.map.

Last edited 9 months ago by slelievre (previous) (diff)

comment:2 Changed 9 months ago by embray

  • Authors set to Erik Bray
  • Branch set to u/embray/ticket-27514
  • Commit set to a7d28a1ee61c46b1335cb46c7a3cf52c9d56a952
  • Status changed from new to needs_review

Fixes the issue with a small bit of refactoring to ensure that the test in question is always actually testing the build_many implementation to which it applies.


New commits:

a7d28a1Ticket #27514: Rename the default implementation of build_many to

comment:3 Changed 8 months ago by embray

Ping?

comment:4 Changed 8 months ago by vbraun

  • Reviewers set to Volker Braun
  • Status changed from needs_review to positive_review

comment:5 Changed 8 months ago by embray

Thank you!

comment:6 Changed 7 months ago by vbraun

  • Branch changed from u/embray/ticket-27514 to a7d28a1ee61c46b1335cb46c7a3cf52c9d56a952
  • Resolution set to fixed
  • Status changed from positive_review to closed

comment:7 Changed 7 months ago by embray

  • Milestone changed from sage-8.8 to sage-8.9

Not in Sage 8.8. Let's please to try keep tickets' milestones related to the release in which we actually intend to include them, and in particular the release in which they were actually included, especially when closing tickets.

Note: See TracTickets for help on using tickets.