Opened 3 years ago

Closed 3 years ago

#27481 closed defect (fixed)

sphinx_plot: Fix regression for 3d plots, suppress axes frame

Reported by: mkoeppe Owned by:
Priority: critical Milestone: sage-8.8
Component: documentation Keywords:
Cc: egourgoulhon Merged in:
Authors: Matthias Koeppe Reviewers: Eric Gourgoulhon
Report Upstream: N/A Work issues:
Branch: 013415d (Commits, GitHub, GitLab) Commit: 013415d709a3a5dabc7a57cfbd3706a23e6bb128
Dependencies: Stopgaps:

Status badges

Change History (9)

comment:1 Changed 3 years ago by mkoeppe

  • Branch set to u/mkoeppe/sphinx_plot__fix_regression_for_3d_plots__suppress_axes_frame

comment:2 Changed 3 years ago by mkoeppe

  • Cc egourgoulhon added
  • Commit set to 013415d709a3a5dabc7a57cfbd3706a23e6bb128

New commits:

013415dsphinx_plot: For 3d objects plotted via png, turn off axes frame

comment:3 follow-up: Changed 3 years ago by egourgoulhon

Thanks for the fix! Is the ticket ready for review?

comment:4 Changed 3 years ago by embray

  • Priority changed from major to critical

I'd say this is pretty important since without it there's a noticeable, if not mostly aesthetic, regression in the documentation.

comment:5 in reply to: ↑ 3 Changed 3 years ago by egourgoulhon

Replying to egourgoulhon:

Thanks for the fix! Is the ticket ready for review?

I've checked the ticket branch: it fixes the issue. So I am ready to give a 'positive review', all the more that the release of 8.7.rc0 is approaching... If you agree, please set the ticket to 'needs review'.

comment:6 Changed 3 years ago by mkoeppe

  • Authors set to Matthias Koeppe
  • Status changed from new to needs_review

comment:7 Changed 3 years ago by egourgoulhon

  • Reviewers set to Eric Gourgoulhon
  • Status changed from needs_review to positive_review

Thanks!

comment:8 Changed 3 years ago by embray

  • Milestone changed from sage-8.7 to sage-8.8

Moving all blocker/critical issues from 8.7 to 8.8.

comment:9 Changed 3 years ago by vbraun

  • Branch changed from u/mkoeppe/sphinx_plot__fix_regression_for_3d_plots__suppress_axes_frame to 013415d709a3a5dabc7a57cfbd3706a23e6bb128
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.