Opened 2 years ago

Closed 2 years ago

#27437 closed defect (duplicate)

MR9: Fix spkg-postinst for pplpy

Reported by: galois Owned by:
Priority: blocker Milestone: sage-duplicate/invalid/wontfix
Component: packages: standard Keywords:
Cc: vklein, vbraun, vdelecroix Merged in:
Authors: E. Madison Bray Reviewers:
Report Upstream: N/A Work issues:
Branch: u/galois/mrs/9/pplpy-postinst (Commits, GitHub, GitLab) Commit: 878a91f13c8b0d6cc2f2f910312132ce4ffd40bd
Dependencies: Stopgaps:

Status badges

Description (last modified by embray)

  1. Madison Bray (@embray) opened a merge request at https://gitlab.com/sagemath/sage/merge_requests/9:

It shouldn't install the docs unless SAGE_SPKG_INSTALL_DOCS=yes explicitly, rather than explicitly checking SAGE_SPKG_INSTALL_DOCS != no.

It should also ensure that sphinx is installed, which is necessary for the doc build.




Change History (4)

comment:1 Changed 2 years ago by embray

  • Cc vklein vbraun added
  • Component changed from PLEASE CHANGE to packages: standard
  • Description modified (diff)
  • Priority changed from major to blocker
  • Type changed from PLEASE CHANGE to defect

It occurs to me now that this is partially a duplicate of #27403, but I still think it's a problem (unless I'm mistaken) that it's building the docs unnecessarily.

comment:2 Changed 2 years ago by vklein

  • Cc vdelecroix added

comment:3 Changed 2 years ago by vklein

It shouldn't install the docs unless SAGE_SPKG_INSTALL_DOCS=yes explicitly, rather than explicitly checking SAGE_SPKG_INSTALL_DOCS != no

It has been done on purpose. Given pplpy is a standard package and that there is intersphinx links between sage documentation and pplpy's documentation, we prefer that pplpy's documentation is installed in the default case (When SAGE_SPKG_INSTALL_DOCS is undefined).

Last edited 2 years ago by vklein (previous) (diff)

comment:4 Changed 2 years ago by embray

  • Milestone changed from sage-8.7 to sage-duplicate/invalid/wontfix
  • Resolution set to duplicate
  • Status changed from needs_review to closed

Alright. I'm not really sure how I feel about that: I don't see why not just do like with other packages and host its documentation online, and download the inventories for intersphinx builds. This is what's done on most projects--I don't know why Sage is trying to be weird about this.

But given that, for now, this was intentional and #27403 has the dependency fix, I'll close as duplicate.

Note: See TracTickets for help on using tickets.