Changes between Version 24 and Version 25 of Ticket #27330


Ignore:
Timestamp:
05/13/19 15:59:30 (3 years ago)
Author:
dimpase
Comment:

Legend:

Unmodified
Added
Removed
Modified
  • Ticket #27330 – Description

    v24 v25  
    5151
    5252* lrslib (#27804)
     53* python2/3 (#27824) this one is of course a very special case; see the ticket for details.
    5354
    54 
    55 ==== Don't Have Tickets ====
    56 
    57 These packages are direct build dependencies of sagelib, and should thus take priority (since if these can be found on the system then one can presume that so too can their dependencies).  I have listed these roughly in order of the number of other ''dependent'' SPKGs these have.  Packages with more dependents should generally take higher priority as well:
    58 
    59 * python2/python3: this one is of course a very special case; while it should be possible/desirable to use a system python, any additional Python packages should optionally be installable into a virtualenv instead of the system site-pacakges, including sagelib itself unless the system ''happens'' to meet all of sagelib's Python dependencies already.  Listing some relevant Python packages below:
    60  * cysignals
    61  * cython
    62  * ipython
    63  * jinja2
    64  * jupyter_core
    65  * numpy
    66  * scipy
    67  * sympy
    68  * pip
    69  * setuptools
    70  * six
     55==== No Tickets yet ====
    7156
    7257* BLAS (openblas / atlas / etc): resolving how to handle finding a usable BLAS should be one of the highest priorities; it faces many of the same issues we faced with MPIR/GMP in #27212, but perhaps with even more complexity)