Opened 2 years ago

Closed 6 months ago

#27318 closed enhancement (duplicate)

Factoring univariate polynomials over function fields

Reported by: swewers Owned by:
Priority: minor Milestone: sage-duplicate/invalid/wontfix
Component: algebra Keywords: function fields, polynomials, factorization
Cc: saraedum Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

The following gives a NotImplementedError?:

  sage: F0.<x> = FunctionField(GF(3))
  sage: R.<y> = F0[]
  sage: F.<y> = F0.extension(y^2 - x)
  sage: S.<t> = F[] 
  sage: f = t^2 - x
  sage: f.factor()

I have some very simple code that I could add which solves this temporarily. It uses prime factorization in multivariate polynomial rings, and so implicitly uses Groebner bases. While there are certainly much better approaches, say, for function fields over finite fields, this code would already be very helpful.

Change History (10)

comment:1 Changed 2 years ago by swewers

  • Authors set to Stefan Wewers
  • Cc Julian Rüth <julian.rueth@…> added

I just noticed that #16572 does this already, but it depends on some thing that have not yet been successfully reviewed.

comment:2 Changed 2 years ago by swewers

  • Cc julian.rueth@… added; Julian Rüth <julian.rueth@…> removed

comment:3 Changed 2 years ago by embray

  • Milestone changed from sage-8.7 to sage-8.8

Ticket retargeted after milestone closed (if you don't believe this ticket is appropriate for the Sage 8.8 release please retarget manually)

comment:4 Changed 2 years ago by saraedum

  • Cc saraedum added; julian.rueth@… removed

comment:5 Changed 2 years ago by saraedum

A bad implementation is better than none in this case. If you want to propose a fix, I am happy to review it. (And I'll try not to take 7 weeks to do so…)

Last edited 2 years ago by saraedum (previous) (diff)

comment:6 Changed 22 months ago by embray

  • Milestone sage-8.8 deleted

As the Sage-8.8 release milestone is pending, we should delete the sage-8.8 milestone for tickets that are not actively being worked on or that still require significant work to move forward. If you feel that this ticket should be included in the next Sage release at the soonest please set its milestone to the next release milestone (sage-8.9).

comment:7 Changed 8 months ago by saraedum

  • Authors Stefan Wewers deleted

comment:8 Changed 8 months ago by saraedum

  • Milestone set to sage-duplicate/invalid/wontfix
  • Status changed from new to needs_review

This is a duplicate of #16572.

comment:9 Changed 8 months ago by saraedum

  • Status changed from needs_review to positive_review

comment:10 Changed 6 months ago by chapoton

  • Resolution set to duplicate
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.