Opened 2 years ago

Closed 2 years ago

#27307 closed defect (duplicate)

incorrect usage of sig_on()/sig_off() in integer_mod.lucas

Reported by: mmezzarobba Owned by:
Priority: minor Milestone: sage-duplicate/invalid/wontfix
Component: finite rings Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: u/mmezzarobba/ticket/27307 (Commits, GitHub, GitLab) Commit: 323cd80c86229997a5f3e497d8aec56d948730f7
Dependencies: Stopgaps:

Status badges

Description

leading to random failures like

File "src/sage/rings/finite_rings/integer_mod.pyx", line 4066, in sage.rings.finite_rings.integer_mod.lucas
Failed example:
    all([lucas(k,p,q,n)[0] == Mod(lucas_number2(k,p,q),n)
         for k in Integers(20)])
Exception raised:
    Traceback (most recent call last):
      File "/home/marc/co/sage/local/lib/python2.7/site-packages/sage/doctest/forker.py", line 671, in _run
        self.compile_and_execute(example, compiler, test.globs)
      File "/home/marc/co/sage/local/lib/python2.7/site-packages/sage/doctest/forker.py", line 1095, in compile_and_execute
        exec(compiled, globs)
      File "<doctest sage.rings.finite_rings.integer_mod.lucas[4]>", line 2, in <module>
        for k in Integers(Integer(20))])
      File "sage/rings/finite_rings/integer_mod.pyx", line 4117, in sage.rings.finite_rings.integer_mod.lucas (build/cythonized/sage/rings/finite_rings/integer_mod.c:38600)
        sig_on()
    SystemError: calling remove_from_pari_stack() inside sig_on()

Change History (4)

comment:1 Changed 2 years ago by mmezzarobba

  • Authors set to Marc Mezzarobba
  • Branch set to u/mmezzarobba/ticket/27307
  • Commit set to 323cd80c86229997a5f3e497d8aec56d948730f7
  • Component changed from PLEASE CHANGE to finite rings
  • Priority changed from major to minor
  • Status changed from new to needs_review
  • Type changed from PLEASE CHANGE to defect

New commits:

323cd80#27307 incorrect usage of sig_on()/sig_off()

comment:2 Changed 2 years ago by chapoton

duplicate of #27282 ?

comment:3 Changed 2 years ago by mmezzarobba

  • Authors Marc Mezzarobba deleted
  • Milestone changed from sage-8.7 to sage-duplicate/invalid/wontfix
  • Status changed from needs_review to positive_review

Indeed, thanks!

comment:4 Changed 2 years ago by jdemeyer

  • Resolution set to duplicate
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.