Opened 8 months ago

Closed 8 months ago

#27257 closed defect (worksforme)

Fix sagenb build

Reported by: jdemeyer Owned by:
Priority: major Milestone: sage-8.7
Component: packages: standard Keywords:
Cc: Konrad127123, zimmerma Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: u/jdemeyer/fix_sagenb_build (Commits) Commit: 3e48fd48f688f68e1eef2889fde3eff818d3f8b2
Dependencies: Stopgaps:

Description


Change History (10)

comment:1 Changed 8 months ago by jdemeyer

  • Branch set to u/jdemeyer/fix_sagenb_build

comment:2 Changed 8 months ago by Konrad127123

  • Cc Konrad127123 added
  • Commit set to 3e48fd48f688f68e1eef2889fde3eff818d3f8b2

New commits:

3e48fd4Get rid of all "except ImportError" for sage

comment:3 follow-up: Changed 8 months ago by jdemeyer

  • Cc zimmerma added

Can you please try to reproduce the problem from #26686 with this branch?

comment:4 in reply to: ↑ 3 Changed 8 months ago by zimmerma

Replying to jdemeyer:

Can you please try to reproduce the problem from #26686 with this branch?

sorry I cannot. I only build Sage releases on my laptop (this takes ages and I have to make sure it does not heat too much).

comment:5 follow-up: Changed 8 months ago by zimmerma

after trying comment 18 in #26686, I can build Sage with make sagenb, but make -j1 still does not want to build the documentation:

$ make -j1
...
[dochtml] [tutorial ] Merging js index files...
[dochtml] [tutorial ] ... done (2115 js index entries)
[dochtml] [tutorial ] The HTML pages are in local/share/doc/sage/html/de/tutorial.
[dochtml] Error building the documentation.
[dochtml] Traceback (most recent call last):
[dochtml]   File "/usr/local/sage-8.6/local/lib/python2.7/runpy.py", line 174, in _run_module_as_main
[dochtml]     "__main__", fname, loader, pkg_name)
[dochtml]   File "/usr/local/sage-8.6/local/lib/python2.7/runpy.py", line 72, in _run_code
[dochtml]     exec code in run_globals
[dochtml]   File "/usr/local/sage-8.6/local/lib/python2.7/site-packages/sage_setup/docbuild/__main__.py", line 2, in <module>
[dochtml]     main()
[dochtml]   File "/usr/local/sage-8.6/local/lib/python2.7/site-packages/sage_setup/docbuild/__init__.py", line 1715, in main
[dochtml]     builder()
[dochtml]   File "/usr/local/sage-8.6/local/lib/python2.7/site-packages/sage_setup/docbuild/__init__.py", line 342, in _wrapper
[dochtml]     build_many(build_other_doc, L)
[dochtml]   File "/usr/local/sage-8.6/local/lib/python2.7/site-packages/sage_setup/docbuild/__init__.py", line 283, in build_many
[dochtml]     ret = x.get(99999)
[dochtml]   File "/usr/local/sage-8.6/local/lib/python2.7/multiprocessing/pool.py", line 572, in get
[dochtml]     raise self._value
[dochtml] OSError: WARNING: search index couldn't be loaded, but not all documents will be built: the index will be incomplete.
[dochtml] 
[dochtml]     Note: incremental documentation builds sometimes cause spurious
[dochtml]     error messages. To be certain that these are real errors, run
[dochtml]     "make doc-clean" first and try again.
Makefile:1993: recipe for target 'doc-html' failed
make[3]: *** [doc-html] Error 1
make[3]: Leaving directory '/usr/local/sage-8.6/build/make'
Makefile:1803: recipe for target 'all-start' failed
make[2]: *** [all-start] Error 2
make[2]: Leaving directory '/usr/local/sage-8.6/build/make'

comment:6 follow-up: Changed 8 months ago by jdemeyer

Does make doc-clean fix that latter error?

comment:7 in reply to: ↑ 6 Changed 8 months ago by zimmerma

Replying to jdemeyer:

Does make doc-clean fix that latter error?

yes it does. Thank you. But it was the first time since years that building Sage from source does not work.

comment:8 in reply to: ↑ 5 ; follow-up: Changed 8 months ago by jdemeyer

So is there anybody that can actually reproduce the problem from #26686? If not, this should be closed as "worksforme".

comment:9 in reply to: ↑ 8 Changed 8 months ago by zimmerma

Replying to jdemeyer:

So is there anybody that can actually reproduce the problem from #26686? If not, this should be closed as "worksforme".

I will try to rebuild Sage 8.6 from scratch, to see if the problem is reproducible.

By the way, while creating this ticket, you should have copied the description of the problem I had, since the description of this ticket is not very informative...

comment:10 Changed 8 months ago by zimmerma

  • Resolution set to worksforme
  • Status changed from new to closed

I tried again building Sage 8.6 from scratch and it worked fine. Since I'm unable to reproduce the problem, we can close that ticket.

Note: See TracTickets for help on using tickets.