Opened 3 years ago

Closed 3 years ago

#27249 closed defect (fixed)

fix doctest in graph_latex

Reported by: dcoudert Owned by:
Priority: major Milestone: sage-8.7
Component: graph theory Keywords:
Cc: slabbe Merged in:
Authors: David Coudert Reviewers: Sébastien Labbé
Report Upstream: N/A Work issues:
Branch: f0eb317 (Commits, GitHub, GitLab) Commit: f0eb3174c34b150108a4d33c9489deb137b57965
Dependencies: Stopgaps:

Status badges

Description

Reported on https://groups.google.com/forum/#!topic/sage-release/0QvdNonpGEg. Doctest failing in dot2tex_picture with 8.7.beta3 and optional package dot2tex.

Change History (5)

comment:1 Changed 3 years ago by dcoudert

  • Branch set to public/27249_dot2tex_picture
  • Commit set to f0eb3174c34b150108a4d33c9489deb137b57965
  • Status changed from new to needs_review

New commits:

f0eb317trac #27249: fix doctest

comment:2 Changed 3 years ago by slabbe

  • Status changed from needs_review to positive_review

It fixes the reported issue.

I was wondering if this was related to bliss? Anyhow, I have bliss installed and with bliss the issue is fixed.

comment:3 Changed 3 years ago by slabbe

  • Reviewers set to Sébastien Labbé

comment:4 Changed 3 years ago by dcoudert

It's related to changes in the ordering of vertices/edges: we don't sort unless mandatory. Typically, for plotting there is no need for sorting the vertices/edges.

Also I forgot to re-install dot2tex after my last dist-clean...

comment:5 Changed 3 years ago by vbraun

  • Branch changed from public/27249_dot2tex_picture to f0eb3174c34b150108a4d33c9489deb137b57965
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.