Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#2724 closed defect (duplicate)

Graph.show3D should have default aspect ratio of [1,1,1]

Reported by: jason Owned by: rlm
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: graph theory Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

In the following:

sage: g=graphs.PetersenGraph()
sage: g.show3d()

the edges look messed up (some are darker and some are lighter and it changes as you rotate the graph). Putting aspect_ratio=[1,1,1] fixes the problem:

sage: g=graphs.PetersenGraph()
sage: g.show3d(aspect_ratio=[1,1,1])

Change History (4)

comment:1 Changed 13 years ago by mabshoff

Might this be a duplicate of #2477, i.e. show3d vs. plot3d? This also has some overlap with #2100.

Cheers,

Michael

comment:2 Changed 13 years ago by rlm

  • Resolution set to duplicate
  • Status changed from new to closed

This is an exact duplicate of #2477. Make sure to check before posting tickets!

comment:3 Changed 13 years ago by jason

You're right, it's a dup of #2477. I tried searching for a ticket, but didn't find that one (I was looking for show3d).

I've posted a review for that patch.

comment:4 Changed 13 years ago by mabshoff

  • Milestone changed from sage-2.11 to sage-duplicate/invalid
Note: See TracTickets for help on using tickets.