Opened 2 years ago

Closed 2 years ago

#27233 closed defect (duplicate)

QQbar fast path doesn't trigger

Reported by: gh-BrentBaccala Owned by:
Priority: minor Milestone: sage-duplicate/invalid/wontfix
Component: algebra Keywords: algebraic field
Cc: Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

The following calculation runs "forever":

sage: g = QQbar(-27/4)^(1/7)
sage: (nf, elems, mor) = number_field_elements_from_algebraics([sqrt(2), sqrt(-1), g])
sage: nf3.<n> = NumberField(nf.polynomial(), embedding=mor(nf.0))
sage: QQbar(-1/108*n^12) == -g

A fast path in qqbar.py's cmp_elements_with_same_minpoly should trigger but doesn't.

Change History (2)

comment:1 Changed 2 years ago by gh-BrentBaccala

  • Milestone changed from sage-8.7 to sage-duplicate/invalid/wontfix

This is a duplicate of #26593

comment:2 Changed 2 years ago by jdemeyer

  • Resolution set to duplicate
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.