Opened 2 years ago

Closed 12 months ago

#27162 closed defect (duplicate)

Cysignals tries to test under py2 in py3 install, fails

Reported by: vbraun Owned by:
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: packages: standard Keywords:
Cc: jdemeyer, jhpalmieri Merged in:
Authors: Reviewers: John Palmieri
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

The cysignals tests fail in a py3 build, apparenty it tries to pip2-install stuff:

[cysignals-1.8.1] Successfully installed cysignals-1.8.1
[cysignals-1.8.1] Cleaning up...
[cysignals-1.8.1] Removed build tracker '/tmp/pip-req-tracker-wtz75jvl'
[cysignals-1.8.1] 
[cysignals-1.8.1] real	0m13.703s
[cysignals-1.8.1] user	0m11.688s
[cysignals-1.8.1] sys	0m0.904s
[cysignals-1.8.1] Copying package files from temporary location /var/lib/buildbot/slave/sage3_git/build/local/var/tmp/sage/build/cysignals-1.8.1/inst to /var/lib/buildbot/slave/sage3_git/build/local
[cysignals-1.8.1] Running the test suite for cysignals-1.8.1...
[cysignals-1.8.1] make[2]: Entering directory '/var/lib/buildbot/slave/sage3_git/build/local/var/tmp/sage/build/cysignals-1.8.1/src'
[cysignals-1.8.1] python -m pip -v install --no-index --ignore-installed --no-deps .
[cysignals-1.8.1] Ignoring indexes: https://pypi.org/simple
[cysignals-1.8.1] Created temporary directory: /tmp/pip-ephem-wheel-cache-5eNAlY
[cysignals-1.8.1] Created temporary directory: /tmp/pip-req-tracker-hmX1P_
[cysignals-1.8.1] Created requirements tracker '/tmp/pip-req-tracker-hmX1P_'
[cysignals-1.8.1] Created temporary directory: /tmp/pip-install-cWxsgh
[cysignals-1.8.1] Processing /var/lib/buildbot/slave/sage3_git/build/local/var/tmp/sage/build/cysignals-1.8.1/src
[cysignals-1.8.1]   Created temporary directory: /tmp/pip-req-build-iM84ye
[cysignals-1.8.1]   Added file:///var/lib/buildbot/slave/sage3_git/build/local/var/tmp/sage/build/cysignals-1.8.1/src to build tracker '/tmp/pip-req-tracker-hmX1P_'
[cysignals-1.8.1]   Running setup.py (path:/tmp/pip-req-build-iM84ye/setup.py) egg_info for package from file:///var/lib/buildbot/slave/sage3_git/build/local/var/tmp/sage/build/cysignals-1.8.1/src
[cysignals-1.8.1]     Running command python setup.py egg_info
[cysignals-1.8.1]     Download error on https://pypi.org/simple/Cython/: [Errno 110] Connection timed out -- Some packages may not be found!
[cysignals-1.8.1]     Couldn't find index page for 'Cython' (maybe misspelled?)
[cysignals-1.8.1]     Download error on https://pypi.org/simple/: [Errno 110] Connection timed out -- Some packages may not be found!
[cysignals-1.8.1]     No local packages or working download links found for Cython>=0.28
[cysignals-1.8.1]     Traceback (most recent call last):
[cysignals-1.8.1]       File "<string>", line 1, in <module>
[cysignals-1.8.1]       File "/tmp/pip-req-build-iM84ye/setup.py", line 149, in <module>
[cysignals-1.8.1]         cmdclass=dict(build=build, bdist_egg=no_egg),
[cysignals-1.8.1]       File "/var/lib/buildbot/slave/sage3_git/build/local/lib/python2.7/site-packages/setuptools/__init__.py", line 142, in setup
[cysignals-1.8.1]         _install_setup_requires(attrs)
[cysignals-1.8.1]       File "/var/lib/buildbot/slave/sage3_git/build/local/lib/python2.7/site-packages/setuptools/__init__.py", line 137, in _install_setup_requires
[cysignals-1.8.1]         dist.fetch_build_eggs(dist.setup_requires)
[cysignals-1.8.1]       File "/var/lib/buildbot/slave/sage3_git/build/local/lib/python2.7/site-packages/setuptools/dist.py", line 586, in fetch_build_eggs
[cysignals-1.8.1]         replace_conflicting=True,
[cysignals-1.8.1]       File "/var/lib/buildbot/slave/sage3_git/build/local/lib/python2.7/site-packages/pkg_resources/__init__.py", line 780, in resolve
[cysignals-1.8.1]         replace_conflicting=replace_conflicting
[cysignals-1.8.1]       File "/var/lib/buildbot/slave/sage3_git/build/local/lib/python2.7/site-packages/pkg_resources/__init__.py", line 1063, in best_match
[cysignals-1.8.1]         return self.obtain(req, installer)
[cysignals-1.8.1]       File "/var/lib/buildbot/slave/sage3_git/build/local/lib/python2.7/site-packages/pkg_resources/__init__.py", line 1075, in obtain
[cysignals-1.8.1]         return installer(requirement)
[cysignals-1.8.1]       File "/var/lib/buildbot/slave/sage3_git/build/local/lib/python2.7/site-packages/setuptools/dist.py", line 653, in fetch_build_egg
[cysignals-1.8.1]         return cmd.easy_install(req)
[cysignals-1.8.1]       File "/var/lib/buildbot/slave/sage3_git/build/local/lib/python2.7/site-packages/setuptools/command/easy_install.py", line 673, in easy_install
[cysignals-1.8.1]         raise DistutilsError(msg)
[cysignals-1.8.1]     distutils.errors.DistutilsError: Could not find suitable distribution for Requirement.parse('Cython>=0.28')
[cysignals-1.8.1] Cleaning up...
[cysignals-1.8.1]   Removing source in /tmp/pip-req-build-iM84ye
[cysignals-1.8.1] Removed file:///var/lib/buildbot/slave/sage3_git/build/local/var/tmp/sage/build/cysignals-1.8.1/src from build tracker '/tmp/pip-req-tracker-hmX1P_'
[cysignals-1.8.1] Removed build tracker '/tmp/pip-req-tracker-hmX1P_'
[cysignals-1.8.1] Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-req-build-iM84ye/
[cysignals-1.8.1] Exception information:
[cysignals-1.8.1] Traceback (most recent call last):
[cysignals-1.8.1]   File "/var/lib/buildbot/slave/sage3_git/build/local/lib/python2.7/site-packages/pip/_internal/cli/base_command.py", line 143, in main
[cysignals-1.8.1]     status = self.run(options, args)
[cysignals-1.8.1]   File "/var/lib/buildbot/slave/sage3_git/build/local/lib/python2.7/site-packages/pip/_internal/commands/install.py", line 318, in run
[cysignals-1.8.1]     resolver.resolve(requirement_set)
[cysignals-1.8.1]   File "/var/lib/buildbot/slave/sage3_git/build/local/lib/python2.7/site-packages/pip/_internal/resolve.py", line 102, in resolve
[cysignals-1.8.1]     self._resolve_one(requirement_set, req)
[cysignals-1.8.1]   File "/var/lib/buildbot/slave/sage3_git/build/local/lib/python2.7/site-packages/pip/_internal/resolve.py", line 256, in _resolve_one
[cysignals-1.8.1]     abstract_dist = self._get_abstract_dist_for(req_to_install)
[cysignals-1.8.1]   File "/var/lib/buildbot/slave/sage3_git/build/local/lib/python2.7/site-packages/pip/_internal/resolve.py", line 209, in _get_abstract_dist_for
[cysignals-1.8.1]     self.require_hashes
[cysignals-1.8.1]   File "/var/lib/buildbot/slave/sage3_git/build/local/lib/python2.7/site-packages/pip/_internal/operations/prepare.py", line 298, in prepare_linked_requirement
[cysignals-1.8.1]     abstract_dist.prep_for_dist(finder, self.build_isolation)
[cysignals-1.8.1]   File "/var/lib/buildbot/slave/sage3_git/build/local/lib/python2.7/site-packages/pip/_internal/operations/prepare.py", line 126, in prep_for_dist
[cysignals-1.8.1]     self.req.run_egg_info()
[cysignals-1.8.1]   File "/var/lib/buildbot/slave/sage3_git/build/local/lib/python2.7/site-packages/pip/_internal/req/req_install.py", line 473, in run_egg_info
[cysignals-1.8.1]     command_desc='python setup.py egg_info')
[cysignals-1.8.1]   File "/var/lib/buildbot/slave/sage3_git/build/local/lib/python2.7/site-packages/pip/_internal/utils/misc.py", line 705, in call_subprocess
[cysignals-1.8.1]     % (command_desc, proc.returncode, cwd))
[cysignals-1.8.1] InstallationError: Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-req-build-iM84ye/
[cysignals-1.8.1] Makefile:26: recipe for target 'install' failed
[cysignals-1.8.1] make[2]: *** [install] Error 1
[cysignals-1.8.1] make[2]: Leaving directory '/var/lib/buildbot/slave/sage3_git/build/local/var/tmp/sage/build/cysignals-1.8.1/src'
[cysignals-1.8.1] 
[cysignals-1.8.1] real	4m14.914s
[cysignals-1.8.1] user	0m0.372s
[cysignals-1.8.1] sys	0m0.064s
[cysignals-1.8.1] ************************************************************************
[cysignals-1.8.1] Error testing package cysignals-1.8.1
[cysignals-1.8.1] ************************************************************************

Change History (9)

comment:1 Changed 2 years ago by chapoton

Makefile starts with

PYTHON = python
PIP = $(PYTHON) -m pip -v

On the other hand, the requirements are "Python 2.7 or Python >= 3.4" in README.rst

comment:2 Changed 2 years ago by jdemeyer

I just literally today found out about setup.py test. Maybe cysignals should use that to test?

comment:3 Changed 2 years ago by embray

  • Milestone changed from sage-8.7 to sage-8.8

Ticket retargeted after milestone closed (if you don't believe this ticket is appropriate for the Sage 8.8 release please retarget manually)

comment:4 Changed 22 months ago by embray

  • Milestone sage-8.8 deleted

As the Sage-8.8 release milestone is pending, we should delete the sage-8.8 milestone for tickets that are not actively being worked on or that still require significant work to move forward. If you feel that this ticket should be included in the next Sage release at the soonest please set its milestone to the next release milestone (sage-8.9).

comment:5 Changed 12 months ago by mkoeppe

  • Milestone set to sage-9.1

comment:6 Changed 12 months ago by mkoeppe

  • Cc jhpalmieri added
  • Milestone changed from sage-9.1 to sage-duplicate/invalid/wontfix
  • Status changed from new to needs_review

This is an outdated duplicate of #28726, should be closed

comment:7 Changed 12 months ago by jhpalmieri

  • Status changed from needs_review to positive_review

comment:8 Changed 12 months ago by mkoeppe

  • Reviewers set to John Palmieri

comment:9 Changed 12 months ago by chapoton

  • Resolution set to duplicate
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.