Opened 4 years ago

Closed 13 months ago

#27150 closed enhancement (invalid)

Better UI for Python 3 Sage doctesting

Reported by: Vincent Delecroix Owned by:
Priority: minor Milestone: sage-duplicate/invalid/wontfix
Component: doctest framework Keywords:
Cc: Frédéric Chapoton Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description (last modified by Jeroen Demeyer)

running sage -t in a Python 2 or Python 3 installation of Sage results in a seemingly wrong set of --optional flags

$ sage -t XXX
...
Using --optional=dochtml,memlimit,mpir,python2,sage
...

In a Python 2 installation the py2 should be there (and the python2 appearing because of a is quite weird). While on Python 3 it should be py3.

See also this sage-devel thread.

Change History (13)

comment:1 Changed 4 years ago by Vincent Delecroix

Description: modified (diff)

comment:2 Changed 4 years ago by Jeroen Demeyer

Description: modified (diff)
Priority: criticalminor
Summary: Fix Python 3 Sage doctestingBetter UI for Python 3 Sage doctesting

It's just a UI issue. Everything is behaving as it should be...

comment:3 Changed 4 years ago by Vincent Delecroix

I don't agree: python2 doctesting is also broken. The py2 tag is not in the optional list and hence ignored.

comment:4 Changed 4 years ago by Jeroen Demeyer

Are you really sure?

comment:5 Changed 4 years ago by Vincent Delecroix

It depends what you mean by "normal". More precisely:

  • the optional py2/py3 do not appear on the command line due to the filtering in line 1018 of doctest/control.py
    return ",".join(sorted(tags - auto_optional_tags))
    
  • the python2 appears in the list because python2 is an optional package (is it installed under any circumstances?)

Both look quite artificial to me.

Conclusion: doctests are not broken - behavior is very confusing.

comment:6 Changed 4 years ago by Jeroen Demeyer

Type: defectenhancement

Everything is working as designed but the design might be confusing. That's why I said that it's an UI issue.

comment:7 Changed 4 years ago by Vincent Delecroix

@jeroen: Do you know whether python2 is always installed? (it got installed on my fresh py3 build). Why is it optional?

comment:8 Changed 4 years ago by Erik Bray

Milestone: sage-8.7sage-8.8

Ticket retargeted after milestone closed (if you don't believe this ticket is appropriate for the Sage 8.8 release please retarget manually)

comment:9 Changed 3 years ago by Erik Bray

Milestone: sage-8.8

As the Sage-8.8 release milestone is pending, we should delete the sage-8.8 milestone for tickets that are not actively being worked on or that still require significant work to move forward. If you feel that this ticket should be included in the next Sage release at the soonest please set its milestone to the next release milestone (sage-8.9).

comment:10 Changed 3 years ago by Frédéric Chapoton

Cc: Frédéric Chapoton added; fchapoton removed

comment:11 Changed 13 months ago by Matthias Köppe

Status: newneeds_review

Outdated, should close

comment:12 Changed 13 months ago by Matthias Köppe

Milestone: sage-duplicate/invalid/wontfix

comment:13 Changed 13 months ago by Frédéric Chapoton

Resolution: invalid
Status: needs_reviewclosed

ok

Note: See TracTickets for help on using tickets.