Opened 3 years ago

Closed 19 months ago

#27118 closed defect (worksforme)

Failing doctests due to syntax warnings from GAP

Reported by: jdemeyer Owned by:
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: packages: standard Keywords:
Cc: dimpase Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

On my system, I have this:

sage -t src/sage/categories/finite_monoids.py
**********************************************************************
File "src/sage/categories/finite_monoids.py", line 73, in sage.categories.finite_monoids.FiniteMonoids.ParentMethods.nerve
Failed example:
    Sigma2 = groups.permutation.Cyclic(2)
Expected nothing
Got:
    Syntax warning: Unbound global variable in /usr/local/src/sage-config/local/sh\
    are/gap/lib/operdebug.g:46
      PrintTo1(fname, f);
              ^
    Syntax warning: Unbound global variable in /usr/local/src/sage-config/local/sh\
    are/gap/lib/operdebug.g:59
          n := SubstitutionSublist(nams[i],"CategoryCollections","CC");
                                  ^
    Syntax warning: Unbound global variable in /usr/local/src/sage-config/local/sh\
    are/gap/lib/operdebug.g:66
      PrintTo1(fname, f);
              ^
    Syntax warning: Unbound global variable in /usr/local/src/sage-config/local/sh\
    are/gap/pkg/SmallGrp-1.3/read.g:25
            READ_SMALL_FUNCS[s] := LoadFunc(Concatenation("small", String(s)));
                            ^
    Syntax warning: Unbound global variable in /usr/local/src/sage-config/local/sh\
    are/gap/pkg/SmallGrp-1.3/read.g:26
            READ_SMALL_FUNCS[s]( Concatenation( "smlgp", String(s), ".g" ),
                            ^
    Syntax warning: Unbound global variable in /usr/local/src/sage-config/local/sh\
    are/gap/pkg/SmallGrp-1.3/read.g:30
        for i in [ 2 .. Length( SMALL_AVAILABLE_FUNCS ) ] do
                                                      ^
    Syntax warning: Unbound global variable in /usr/local/src/sage-config/local/sh\
    are/gap/pkg/SmallGrp-1.3/read.g:32
            READ_IDLIB_FUNCS[ i ] := LoadFunc(Concatenation("id", String(i)));
                            ^
    Syntax warning: Unbound global variable in /usr/local/src/sage-config/local/sh\
    are/gap/pkg/SmallGrp-1.3/read.g:33
            READ_IDLIB_FUNCS[ i ]( Concatenation( "idgrp", String( i ), ".g" ),
                            ^
    Error, Variable: 'READ_SMALL_FUNCS' must have an assigned value
    Error, was not in any namespace
**********************************************************************

Various other doctests fail with the same messages.

Change History (10)

comment:1 Changed 3 years ago by dimpase

Please specify what Sage version this is and whether you have gap_packages installed.

comment:2 Changed 3 years ago by jdemeyer

sgae 8.7.beta0 with gap_packages installed. Reinstalling gap_packages does not help.

I cannot reproduce (yet) this on other systems, this just happens with one Sage installation.

comment:3 follow-up: Changed 3 years ago by dimpase

How about reinstalling gap and gap_packages?

(and making sure old GAP is purged from SAGE_LOCAL - this is supposed to be automatic, but...)

comment:4 in reply to: ↑ 3 Changed 3 years ago by jdemeyer

Replying to dimpase:

and making sure old GAP is purged from SAGE_LOCAL - this is supposed to be automatic, but...

If this is required, then that's a bug.

comment:5 Changed 3 years ago by jdemeyer

Reinstalling GAP solved the problem.

comment:6 Changed 3 years ago by dimpase

  • Priority changed from blocker to major

reinstalling GAP is not required, but there is no telling about how you mangled your SAGE_LOCAL, so I cannot consider this a bug - surely it should not be a blocker.

I imagine you cannot reproduce it anyway :-)

comment:7 Changed 3 years ago by embray

  • Milestone changed from sage-8.7 to sage-8.8

Ticket retargeted after milestone closed (if you don't believe this ticket is appropriate for the Sage 8.8 release please retarget manually)

comment:8 Changed 3 years ago by embray

  • Milestone sage-8.8 deleted

As the Sage-8.8 release milestone is pending, we should delete the sage-8.8 milestone for tickets that are not actively being worked on or that still require significant work to move forward. If you feel that this ticket should be included in the next Sage release at the soonest please set its milestone to the next release milestone (sage-8.9).

comment:9 Changed 20 months ago by slelievre

  • Milestone set to sage-duplicate/invalid/wontfix
  • Status changed from new to needs_review

Proposing to close as worksforme since there has been no recent manifestation of this.

comment:10 Changed 19 months ago by chapoton

  • Resolution set to worksforme
  • Status changed from needs_review to closed
Note: See TracTickets for help on using tickets.