Changes between Version 14 and Version 17 of Ticket #27063


Ignore:
Timestamp:
10/18/19 07:44:59 (3 years ago)
Author:
jipilab
Comment:

Finally, it might make sense to move code to CombinatorialPolyhedron. E.g. is_prism can be checked there and should only be checked there to avoid code duplication.

Yes, I agree, I adapted the description of the ticket.

Legend:

Unmodified
Added
Removed
Modified
  • Ticket #27063

    • Property Status changed from needs_review to needs_work
    • Property Type changed from enhancement to task
    • Property Summary changed from Polyhedron: let CombinatorialPolyhedron do all combinatorial calculations to Transition of combinatorial computations of Polyhedron to Combinatorial Type
  • Ticket #27063 – Description

    v14 v17  
    33The goal of this ticket is to make use of this class through `Polyhedron_base`.
    44
    5 Add:
     5Add methods:
    66
    7 - #28621: `combinatorial_polyhedron`,
     7- Add method `combinatorial_polyhedron` #28621
    88- a face iterator,
    99- facet graph
    1010
    11 Replace:
     11Replace the existing computation:
    1212
    13 - #28625: `f_vector`,
     13- `f_vector` : #28625,
    1414- `faces`,
    1515- `graph`/`vertex_graph`, `vertex_adjacency_matrix`, `vertex_digraph`
     
    1717- `face_lattice`.
    1818
    19 Finally, it might make sense to move code to `CombinatorialPolyhedron`. E.g. `is_prism` can be checked there and should only be checked there to avoid code duplication.
     19Migrate code to CombinatorialPolyhedron:
     20
     21- `is_prism`