Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#27058 closed enhancement (duplicate)

Upgrade to Cython 0.29.2

Reported by: Samuel Lelièvre Owned by:
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: packages: standard Keywords: upgrade, cython
Cc: Erik Bray, François Bissey, Jeroen Demeyer, Julian Rüth, Samuel Lelièvre Merged in:
Authors: Reviewers: Erik Bray
Report Upstream: N/A Work issues:
Branch: u/jdemeyer/upgrade_to_cython_0_29_2 (Commits, GitHub, GitLab) Commit: 40132ee4d7a8a95b641abdbe11787ee833717b1c
Dependencies: Stopgaps:

Status badges

Description (last modified by Samuel Lelièvre)

Upgrade to Cython 0.29.2.

Tarball: https://files.pythonhosted.org/packages/c1/f2/d1207fd0dfe5cb4dbb06a035eb127653821510d896ce952b5c66ca3dafa4/Cython-0.29.2.tar.gz

This is required for upgrading to NumPy 1.16.0 (#27000).

Our previous upgrade was to Cython 0.29.1 in #25292.

Change History (13)

comment:1 Changed 4 years ago by Samuel Lelièvre

Description: modified (diff)

comment:2 Changed 4 years ago by Jeroen Demeyer

Authors: Jeroen Demeyer
Milestone: sage-8.6sage-8.7

I wonder why numpy insists on Cython 0.29.2, but this upgrade should be trivial.

comment:3 Changed 4 years ago by Jeroen Demeyer

Branch: u/jdemeyer/upgrade_to_cython_0_29_2

comment:4 Changed 4 years ago by François Bissey

Commit: 40132ee4d7a8a95b641abdbe11787ee833717b1c
Reviewers: François Bissey

Have been using it in sage-on-gentoo since 17/12/2018 and I have done quite a few builds and doctests runs with that. So I think it is OK :)

Positive review from me when you are ready.


New commits:

40132eeCython 0.29.2

comment:5 Changed 4 years ago by Jeroen Demeyer

Status: newneeds_review

comment:6 Changed 4 years ago by Jeroen Demeyer

Status: needs_reviewpositive_review

comment:7 Changed 4 years ago by Erik Bray

According to the release notes for Numpy 1.16 it requires just Cython>=0.29. I'm not sure where the "0.29.2" claim is coming from.

Version 0, edited 4 years ago by Erik Bray (next)

comment:8 Changed 4 years ago by Erik Bray

Well, it comes directly from the release announcement: https://mail.python.org/pipermail/numpy-discussion/2019-January/079130.html Though in the Numpy 1.16 tag itself it only specifies "Cython>=0.29". I think I'm on numpy-discussion so I'll ask, though at this point it's mostly just for edification.

comment:9 Changed 4 years ago by Jeroen Demeyer

Don't worry about it. It's not really important whether it requires Cython-0.29 or Cython-0.29.2. I was just asking for curiosity.

It's not a bad idea to upgrade Cython anyway, since it is supposed to fix a memory leak.

comment:10 Changed 4 years ago by Erik Bray

I didn't bother asking but I did find the relevant issue in Numpy and it was exactly because of said memory leak.

comment:11 Changed 4 years ago by Samuel Lelièvre

Milestone: sage-8.7sage-duplicate/invalid/wontfix
Status: positive_reviewneeds_review

Fixed by #26969.

comment:12 Changed 4 years ago by Erik Bray

Resolution: duplicate
Status: needs_reviewclosed

Yes, apparently so...

comment:13 Changed 4 years ago by Samuel Lelièvre

Authors: Jeroen Demeyer
Reviewers: François BisseyErik Bray

If I understand correctly, our convention for duplicate/invalid/wontfix is to have no author and only a reviewer (who reviewed that this is duplicate/invalid/wontfix).

Note: See TracTickets for help on using tickets.