Opened 9 months ago

Closed 9 months ago

#27006 closed defect (duplicate)

cannot convert back polynomials from libgap

Reported by: chapoton Owned by:
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: interfaces Keywords: libgap
Cc: embray Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description

sage: x=polygen(QQ,'x')
sage: f=x+1
sage: g=libgap(f)
sage: g
x+1
sage: g.sage()
---------------------------------------------------------------------------
NotImplementedError                       Traceback (most recent call last)
<ipython-input-71-2462cdd49bf3> in <module>()
----> 1 g.sage()

/home/chapoton/sage3/local/lib/python3.6/site-packages/sage/libs/gap/element.pyx in sage.libs.gap.element.GapElement.sage (build/cythonized/sage/libs/gap/element.c:12055)()
   1209             return -Infinity
   1210 
-> 1211         raise NotImplementedError('cannot construct equivalent Sage object')
   1212 
   1213 

NotImplementedError: cannot construct equivalent Sage object

Change History (2)

comment:1 Changed 9 months ago by chapoton

  • Milestone changed from sage-8.6 to sage-duplicate/invalid/wontfix
  • Status changed from new to needs_review

duplicate of #21020, please close

comment:2 Changed 9 months ago by embray

  • Resolution set to duplicate
  • Status changed from needs_review to closed
Note: See TracTickets for help on using tickets.