Opened 17 months ago

Closed 16 months ago

Last modified 13 months ago

#26997 closed defect (fixed)

5 internet doctests failing in findstat.py

Reported by: slabbe Owned by:
Priority: major Milestone: sage-8.7
Component: doctest coverage Keywords:
Cc: vklein Merged in:
Authors: Martin Rubey Reviewers: Frédéric Chapoton
Report Upstream: N/A Work issues:
Branch: 6079bf0 (Commits) Commit:
Dependencies: Stopgaps:

Description

On Ubuntu 16.04, running sage-8.5.beta1, the command

sage -t --long --optional=sage,internet src/sage/databases/findstat.py

gives

...
3 items had failures:
   3 of  16 in sage.databases.findstat
   1 of   4 in sage.databases.findstat.FindStatStatistic.__repr__
   1 of   9 in sage.databases.findstat.FindStatStatistic._find_by_values
    [247 tests, 5 failures, 107.27 s]
----------------------------------------------------------------------
sage -t --long src/sage/databases/findstat.py  # 5 doctests failed
----------------------------------------------------------------------

Full failure log is long and is pasted here: https://framabin.org/p/?b9dacda8324c7295#71YTYesLKEKBCNg1LtnDUhKkWDrcm+xiZGDI9a8bjfg=

Change History (9)

comment:1 Changed 17 months ago by mantepse

The problem is that the semantics of FancyTuple changed, and I think in a bad way:

sage: FancyTuple([(1,2,3),(4,5,6)])
0: 0: 1
1: 2
2: 3
1: 0: 4
1: 5
2: 6

sage: FancyTuple([[1,2,3],(4,5,6)])
0: [1, 2, 3]
1: 0: 4
1: 5
2: 6

I think this comes from #26704 but I didn't check.

Last edited 17 months ago by mantepse (previous) (diff)

comment:2 Changed 17 months ago by mantepse

  • Branch set to u/mantepse/5_internet_doctests_failing_in_findstat_py

comment:3 Changed 17 months ago by mantepse

  • Commit set to 6079bf06704d5e6080779d4140ad46c6943a1d23

easy fix, according to the specification of FancyTuple.__getitem__.


New commits:

6079bf0fix __getitem__ of FancyTuple to preserve tuple-items

comment:4 Changed 17 months ago by mantepse

  • Authors set to Martin Rubey
  • Status changed from new to needs_review

comment:5 Changed 17 months ago by mantepse

  • Cc vklein added

comment:6 Changed 17 months ago by chapoton

  • Reviewers set to Frédéric Chapoton
  • Status changed from needs_review to positive_review

seems to be ok on python3

comment:7 Changed 17 months ago by embray

  • Milestone changed from sage-8.6 to sage-8.7

Retarging tickets optimistically to the next milestone. If you are responsible for this ticket (either its reporter or owner) and don't believe you are likely to complete this ticket before the next release (8.7) please retarget this ticket's milestone to sage-pending or sage-wishlist.

comment:8 Changed 16 months ago by vbraun

  • Branch changed from u/mantepse/5_internet_doctests_failing_in_findstat_py to 6079bf06704d5e6080779d4140ad46c6943a1d23
  • Resolution set to fixed
  • Status changed from positive_review to closed

comment:9 Changed 13 months ago by slabbe

  • Commit 6079bf06704d5e6080779d4140ad46c6943a1d23 deleted

5 new other failing internet doctests in findstat at #27838

Note: See TracTickets for help on using tickets.