Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#26953 closed defect (fixed)

Allow python3 system python

Reported by: vbraun Owned by: embray
Priority: major Milestone: sage-8.6
Component: build Keywords:
Cc: embray, chapoton Merged in:
Authors: Frédéric Chapoton Reviewers: Volker Braun
Report Upstream: N/A Work issues:
Branch: b7c84b7 (Commits, GitHub, GitLab) Commit:
Dependencies: Stopgaps:

Status badges

Description

On a python3-only system its likely that there is no python command, since PEP394 argues for /usr/bin/python to be python2 only for now. In particular, the Debian 10 buildbot doesn't have python (since it uses python3 buildbot).

The problem is that our sage-system-python script only looks for python, it should fall back to python3

Change History (6)

comment:1 Changed 3 years ago by embray

  • Owner changed from (none) to embray

comment:2 Changed 3 years ago by chapoton

  • Authors set to Frédéric Chapoton
  • Branch set to u/chapoton/26953
  • Commit set to b7c84b72a3ffb3611d920d0493269ac1dc33e72c
  • Status changed from new to needs_review

New commits:

b7c84b7trac 26953 : fallback for systems having only python3 command

comment:3 Changed 3 years ago by vbraun

  • Reviewers set to Volker Braun
  • Status changed from needs_review to positive_review

comment:4 Changed 3 years ago by vbraun

  • Branch changed from u/chapoton/26953 to b7c84b72a3ffb3611d920d0493269ac1dc33e72c
  • Resolution set to fixed
  • Status changed from positive_review to closed

comment:5 Changed 3 years ago by embray

  • Commit b7c84b72a3ffb3611d920d0493269ac1dc33e72c deleted

I would've just checked for python3 first, but we can try it like this for now; it doesn't matter much I don't think since the build tools ostensibly support both Python 2 and 3.

comment:6 Changed 3 years ago by jdemeyer

There is still a problem remaining with zn_poly: #27260

Note: See TracTickets for help on using tickets.