Opened 14 years ago

Closed 9 years ago

#2694 closed enhancement (worksforme)

Hecke algebra basis not implemented

Reported by: syazdani Owned by: craigcitro
Priority: minor Milestone: sage-duplicate/invalid/wontfix
Component: modular forms Keywords:
Cc: Merged in:
Authors: Reviewers: Travis Scrimshaw
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

Hecke algebra basis is not implemented. here is how one can reproduce it:

sage: M=ModularSymbols(431,2,1)
sage: C=M.cuspidal_submodule()
sage: TT=C.hecke_algebra()
sage: TT.basis()
---------------------------------------------------------------------------
<type 'exceptions.NotImplementedError'>   Traceback (most recent call last)

/home/syazdani/sage-2.11.alpha1/<ipython console> in <module>()

/home/syazdani/sage/local/lib/python2.5/site-packages/sage/modular/hecke/algebra.py in basis(self)
    145
    146     def basis(self):
--> 147         raise NotImplementedError
    148
    149     def discriminant(self):

<type 'exceptions.NotImplementedError'>:

Change History (5)

comment:1 Changed 14 years ago by mabshoff

  • Milestone set to sage-2.11

comment:2 Changed 13 years ago by mabshoff

Craig,

any progress here?

Cheers,

Michael

comment:3 Changed 9 years ago by tscrim

  • Milestone changed from sage-5.7 to sage-duplicate/invalid/wontfix
  • Report Upstream set to N/A
  • Status changed from new to needs_review

This works for me on 5.5.rc0:

sage: M = ModularSymbols(431,2,1)
sage: C = M.cuspidal_submodule()
sage: TT = C.hecke_algebra()
sage: TT.basis()
[Hecke operator on Modular Symbols subspace of dimension 36 of Modular Symbols space of dimension 37 for Gamma_0(431) of weight 2 with sign 1 over Rational Field defined by:
...
36 x 36 dense matrix over Rational Field]

comment:4 Changed 9 years ago by cnassau

  • Status changed from needs_review to positive_review

It also works for me in 5.7.beta4 so I'm giving the wontfix a positive review.

comment:5 Changed 9 years ago by jdemeyer

  • Resolution set to worksforme
  • Reviewers set to Travis Scrimshaw
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.