Opened 3 years ago

Closed 3 years ago

#26900 closed enhancement (fixed)

Upgrade to cysignals-1.8.1

Reported by: jdemeyer Owned by:
Priority: major Milestone: sage-8.6
Component: packages: standard Keywords:
Cc: Merged in:
Authors: Jeroen Demeyer Reviewers: Travis Scrimshaw
Report Upstream: N/A Work issues:
Branch: a4a0621 (Commits, GitHub, GitLab) Commit: a4a0621f41ca7eb74479eb9d2e376686da1b5baf
Dependencies: Stopgaps:

Status badges

Change History (14)

comment:1 Changed 3 years ago by jdemeyer

  • Branch set to u/jdemeyer/upgrade_to_cysignals_1_8_0

comment:2 Changed 3 years ago by git

  • Commit set to 1d26b4b2aa423e921aee8214526f67a7c3811d6d

Branch pushed to git repo; I updated commit sha1. This was a forced push. New commits:

1d26b4bUpgrade to cysignals-1.8.0

comment:3 Changed 3 years ago by jdemeyer

  • Status changed from new to needs_review

comment:4 Changed 3 years ago by tscrim

  • Reviewers set to Travis Scrimshaw
  • Status changed from needs_review to positive_review

To my buildbots, I bestow onto you this ticket.

comment:5 Changed 3 years ago by gh-timokau

Is there any chance this test error may be caused by the cysignals upgrade? It occurred shortly after I committed the cysignals 1.8.0 update (on 2018-12-15). Since cysignals is involved and I don't see any other mention of this error, it seems likely that the bug was introduced by this update.

The build server has recovered by now, so the error is not reproduceable.

comment:6 Changed 3 years ago by jdemeyer

The code in cysignals dealing with dying processes has not changed in the latest upgrade. So I don't see any immediate reason why this upgrade would cause that Nix testing error.

comment:7 follow-up: Changed 3 years ago by gh-timokau

It seems like a pretty big coincidence that this happened on the second rebuild after the cysignals update while it was never reported before. But it may be just that, a coincidence.

comment:8 in reply to: ↑ 7 Changed 3 years ago by jdemeyer

Replying to gh-timokau:

But it may be just that, a coincidence.

See my reply in sage-packaging: it really was just a coincidence

comment:9 Changed 3 years ago by jdemeyer

  • Description modified (diff)
  • Status changed from positive_review to needs_work
  • Summary changed from Upgrade to cysignals-1.8.0 to Upgrade to cysignals-1.8.1

It turns out that a few tweaks were needed to cysignals to support #24986, leading to version 1.8.1

Last edited 3 years ago by jdemeyer (previous) (diff)

comment:10 Changed 3 years ago by git

  • Commit changed from 1d26b4b2aa423e921aee8214526f67a7c3811d6d to a4a0621f41ca7eb74479eb9d2e376686da1b5baf

Branch pushed to git repo; I updated commit sha1. This was a forced push. New commits:

a4a0621Upgrade to cysignals-1.8.1

comment:11 Changed 3 years ago by jdemeyer

  • Status changed from needs_work to needs_review

comment:12 Changed 3 years ago by gh-timokau

I think you're missing a digit in the ticket reference.

comment:13 Changed 3 years ago by tscrim

  • Status changed from needs_review to positive_review

Back to the buildbots.

comment:14 Changed 3 years ago by vbraun

  • Branch changed from u/jdemeyer/upgrade_to_cysignals_1_8_0 to a4a0621f41ca7eb74479eb9d2e376686da1b5baf
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.