Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#26877 closed defect (fixed)

Bugfix: basis method of FusionRing

Reported by: bump Owned by:
Priority: major Milestone: sage-8.6
Component: combinatorics Keywords: FusionRing
Cc: tscrim, sage-combinat, bump Merged in:
Authors: Daniel Bump Reviewers: Travis Scrimshaw
Report Upstream: N/A Work issues:
Branch: ed74e83 (Commits, GitHub, GitLab) Commit: ed74e838efbd460739de5f1613e9ab0923f26e48
Dependencies: Stopgaps:

Status badges

Description

For Type A and Type E6, E7 Fusion rings the roots do not span the ambient space. The basis should be projected into the space spanned by the roots.

sage: A22=FusionRing("A2",2)
sage: A22.basis()
Finite family {(0, 0, 0): A22(0,0), (1, 1, 0): A22(0,1), (1, 0, 0):
A22(1,0), (2, 0, 0): A22(2,0), (2, 2, 0): A22(0,2), (2, 1, 0): A22(1,1)}
sage: b=A22.basis().list()[2]; b
A22(1,0)
sage: b.highest_weight()
(1, 0, 0)
sage: A22(1,0).highest_weight()
(2/3, -1/3, -1/3)

The last two answers should be the same. The fix is to run the from_vector_notation method of the ambient space on the basis.

Change History (11)

comment:1 Changed 4 years ago by bump

  • Branch set to public/fusion-bugfix-26877
  • Commit set to 4d57a8a407a9296de2a109de44cca83e7216e6a4

New commits:

4d57a8arun from_vector_notation on basis

comment:2 Changed 4 years ago by bump

  • Component changed from PLEASE CHANGE to combinatorics
  • Type changed from PLEASE CHANGE to defect

comment:3 follow-up: Changed 4 years ago by tscrim

Ready for a full review?

comment:4 Changed 4 years ago by tscrim

  • Authors set to Daniel Bump
  • Reviewers set to Travis Scrimshaw

comment:5 Changed 4 years ago by bump

  • Status changed from new to needs_review

comment:6 in reply to: ↑ 3 Changed 4 years ago by bump

Replying to tscrim:

Ready for a full review?

I changed the ticket to needs review.

One minor point: you had originally suggested making this test conditional on style="coroots".

But if FusionRing is used as intended, style will be "coroots" every time this code is reached, because the test is already conditioned on k is not None. So I omitted the test and pass style=style to the from_vector_notation.

comment:7 Changed 4 years ago by git

  • Commit changed from 4d57a8a407a9296de2a109de44cca83e7216e6a4 to ed74e838efbd460739de5f1613e9ab0923f26e48

Branch pushed to git repo; I updated commit sha1. New commits:

51fdd2bMerge branch 'public/fusion-bugfix-26877' of git://trac.sagemath.org/sage into public/fusion-bugfix-26877
ed74e83Small reviewer fixes to weyl_characters.py.

comment:8 Changed 4 years ago by tscrim

Good point about the style. I made a few small changes. If my changes are good, then positive review.

comment:9 Changed 4 years ago by bump

  • Status changed from needs_review to positive_review

comment:10 Changed 4 years ago by vbraun

  • Branch changed from public/fusion-bugfix-26877 to ed74e838efbd460739de5f1613e9ab0923f26e48
  • Resolution set to fixed
  • Status changed from positive_review to closed

comment:11 Changed 4 years ago by embray

  • Milestone changed from sage-8.5 to sage-8.6

This tickets were closed as fixed after the Sage 8.5 release.

Note: See TracTickets for help on using tickets.