Opened 2 years ago

Closed 2 years ago

#26841 closed defect (duplicate)

Random failure from random chordal graph

Reported by: vbraun Owned by:
Priority: major Milestone: sage-8.5
Component: graph theory Keywords: random_fail
Cc: tscrim, dcoudert Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

This was introduced in #26730

File "src/sage/graphs/generators/random.py", line 907, in sage.graphs.generators.random.connecting_nodes
Failed example:
    S = connecting_nodes(T, 5)
Exception raised:
    Traceback (most recent call last):
      File "/home/buildbot/slave/sage_git/build/local/lib/python2.7/site-packages/sage/doctest/forker.py", line 671, in _run
        self.compile_and_execute(example, compiler, test.globs)
      File "/home/buildbot/slave/sage_git/build/local/lib/python2.7/site-packages/sage/doctest/forker.py", line 1086, in compile_and_execute
        exec(compiled, globs)
      File "<doctest sage.graphs.generators.random.connecting_nodes[2]>", line 1, in <module>
        S = connecting_nodes(T, Integer(5))
      File "/home/buildbot/slave/sage_git/build/local/lib/python2.7/site-packages/sage/graphs/generators/random.py", line 973, in connecting_nodes
        S.append(Ti)
    UnboundLocalError: local variable 'Ti' referenced before assignment
**********************************************************************
File "src/sage/graphs/generators/random.py", line 908, in sage.graphs.generators.random.connecting_nodes
Failed example:
    len(S)
Exception raised:
    Traceback (most recent call last):
      File "/home/buildbot/slave/sage_git/build/local/lib/python2.7/site-packages/sage/doctest/forker.py", line 671, in _run
        self.compile_and_execute(example, compiler, test.globs)
      File "/home/buildbot/slave/sage_git/build/local/lib/python2.7/site-packages/sage/doctest/forker.py", line 1086, in compile_and_execute
        exec(compiled, globs)
      File "<doctest sage.graphs.generators.random.connecting_nodes[3]>", line 1, in <module>
        len(S)
    NameError: name 'S' is not defined
**********************************************************************
1 item had failures:
   2 of   5 in sage.graphs.generators.random.connecting_nodes
    [165 tests, 2 failures, 4.48 s]
----------------------------------------------------------------------
sage -t --long src/sage/graphs/generators/random.py  # 2 doctests failed
----------------------------------------------------------------------

Change History (1)

comment:1 Changed 2 years ago by vbraun

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #26808

Note: See TracTickets for help on using tickets.