#26705 closed defect (fixed)

Fix is_formal for hyperplane arrangements with no cycles

Reported by: tscrim Owned by:
Priority: major Milestone: sage-8.5
Component: geometry Keywords:
Cc: Merged in:
Authors: Travis Scrimshaw Reviewers: Frédéric Chapoton
Report Upstream: N/A Work issues:
Branch: bc3829b (Commits) Commit: bc3829b354333369345f0e786dbba19d0ee55596
Dependencies: Stopgaps:

Description

sage: w = WeylGroup(['A',4]).from_reduced_word([3,4,2,1])
sage: I = w.inversion_arrangement()
sage: I.minimal_generated_number()
4
sage: I.is_formal()
False
sage: I
Arrangement <a4 | a1 | a1 + a2 | a1 + a2 + a3 + a4>

The problem is that there are no circuits, so this should return 0.

Change History (5)

comment:1 Changed 13 months ago by tscrim

  • Branch set to public/geometry/fix_kgenerated_no_dependencies-26705
  • Commit set to a6419080b6389e80748cd373f25d9d5976a0feaa
  • Status changed from new to needs_review

New commits:

a641908Fixing corner case of is_formal.

comment:2 Changed 13 months ago by chapoton

looks ok. Please fix the pyflakes warnings ; once done you can set to positive

comment:3 Changed 13 months ago by git

  • Commit changed from a6419080b6389e80748cd373f25d9d5976a0feaa to bc3829b354333369345f0e786dbba19d0ee55596

Branch pushed to git repo; I updated commit sha1. New commits:

bc3829bFix pyflakes warnings in arrangement.py.

comment:4 Changed 13 months ago by tscrim

  • Reviewers set to Frédéric Chapoton
  • Status changed from needs_review to positive_review

Done. Thank you.

comment:5 Changed 13 months ago by vbraun

  • Branch changed from public/geometry/fix_kgenerated_no_dependencies-26705 to bc3829b354333369345f0e786dbba19d0ee55596
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.