Opened 7 months ago

Closed 7 months ago

#26591 closed defect (duplicate)

py3: log(int(7), base=2) returns 1

Reported by: slabbe Owned by:
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: python3 Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description

8.5.beta1:

sage: log(int(7), base=2)
log(7)/log(2)

8.5.beta1 with Python3 is wrong:

sage: log(int(7), base=2)
1

Change History (3)

comment:1 Changed 7 months ago by chapoton

  • Milestone changed from sage-8.5 to sage-duplicate/invalid/wontfix
  • Status changed from new to needs_review

duplicate of #25979

comment:2 Changed 7 months ago by slabbe

  • Status changed from needs_review to positive_review

comment:3 Changed 7 months ago by embray

  • Resolution set to duplicate
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.