Opened 16 months ago

Closed 15 months ago

Last modified 15 months ago

#26427 closed defect (fixed)

add doctest to charpoly method of symbolic matrices

Reported by: tmonteil Owned by:
Priority: major Milestone: sage-8.5
Component: symbolics Keywords:
Cc: rws Merged in:
Authors: Thierry Monteil Reviewers: Frédéric Chapoton
Report Upstream: N/A Work issues:
Branch: 52e1dc2 (Commits) Commit: 52e1dc29b94def1cb6fc39a70ea3c61ecf7fd71e
Dependencies: Stopgaps:

Description

As reported on this ask question, the following gives wrong result on Archlinux. Though this distro is not officially supported, this example shows some unexpected behaviour that might appear elsewhere, hence it makes sense to add it on the Sage doctests.

sage: M = matrix(SR, 7, 7, SR.var('a', 49))
sage: M.charpoly().degree()
7

Change History (10)

comment:1 Changed 16 months ago by tmonteil

  • Branch set to u/tmonteil/add_doctest_to_charpoly_method_of_symbolic_matices

comment:2 Changed 16 months ago by tmonteil

  • Commit set to 9000bf56874c9adfa609f166d3fa307403258724
  • Status changed from new to needs_review
  • Summary changed from add doctest to charpoly method of symbolic matices to add doctest to charpoly method of symbolic matrices

New commits:

9000bf5#26427 : add doctest for charpoly of matrices over symbolic ring

comment:3 Changed 16 months ago by arojas

  • Cc rws added

FTR, the incorrect result was caused by building pynac with giac support.

comment:4 Changed 16 months ago by chapoton

should be tagged "long" ?

Warning, slow doctest:
    M.charpoly().degree()
Test ran for 1.53 s

comment:5 Changed 16 months ago by git

  • Commit changed from 9000bf56874c9adfa609f166d3fa307403258724 to 133215627425ce61b13d0d53278cbb624ccb1fea

Branch pushed to git repo; I updated commit sha1. New commits:

1332156#26427 : log time doctest

comment:6 Changed 16 months ago by git

  • Commit changed from 133215627425ce61b13d0d53278cbb624ccb1fea to 52e1dc29b94def1cb6fc39a70ea3c61ecf7fd71e

Branch pushed to git repo; I updated commit sha1. This was a forced push. New commits:

52e1dc2#26427 : long time doctest

comment:7 Changed 16 months ago by tmonteil

You are right, thanks for noticing, i updated the doctest.

comment:8 Changed 16 months ago by chapoton

  • Reviewers set to Frédéric Chapoton
  • Status changed from needs_review to positive_review

ok

comment:9 Changed 15 months ago by vbraun

  • Branch changed from u/tmonteil/add_doctest_to_charpoly_method_of_symbolic_matices to 52e1dc29b94def1cb6fc39a70ea3c61ecf7fd71e
  • Resolution set to fixed
  • Status changed from positive_review to closed

comment:10 Changed 15 months ago by embray

  • Milestone changed from sage-8.4 to sage-8.5

This should be re-targeted for 8.5.

Note: See TracTickets for help on using tickets.