Opened 3 years ago

Closed 2 years ago

#26367 closed defect (duplicate)

update gdb package

Reported by: dimpase Owned by:
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: packages: optional Keywords:
Cc: Merged in:
Authors: Dima Pasechnik Reviewers:
Report Upstream: N/A Work issues:
Branch: u/dimpase/packages/gdb82 (Commits, GitHub, GitLab) Commit: 495650adb5bf3a77c9a688c6e460d51a1420b01f
Dependencies: Stopgaps:

Status badges

Description (last modified by dimpase)

gdb 7.8 cannot be built on new Linux kernels (at least on 4.16.6, on Gentoo x86_64), it seems:

...
gcc -g -O2   -I. -I. -I./common -I./config -DLOCALEDIR="\"/mnt/opt/Sage/sage-de
v/local/share/locale\"" -DHAVE_CONFIG_H -I./../include/opcode -I./../opcodes/..
 -I./../readline/.. -I../bfd -I./../bfd -I./../include -I../libdecnumber -I./..
/libdecnumber  -I./gnulib/import -Ibuild-gnulib/import   -DTUI=1   -I/mnt/opt/S
age/sage-dev/local/include -pthread -I/usr/include/guile/2.2 -I/mnt/opt/Sage/sa
ge-dev/local/include/python2.7 -I/mnt/opt/Sage/sage-dev/local/include/python2.7
 -Wall -Wdeclaration-after-statement -Wpointer-arith -Wpointer-sign -Wno-unused
 -Wunused-value -Wunused-function -Wno-switch -Wno-char-subscripts -Wmissing-pr
ototypes -Wdeclaration-after-statement -Wempty-body -Wmissing-parameter-type -W
old-style-declaration -Wold-style-definition -Wformat-nonliteral  -c -o amd64-linux-nat.o -MT amd64-linux-nat.o -MMD -MP -MF .deps/amd64-linux-nat.Tpo amd64-linux-nat.c
amd64-linux-nat.c:497:1: error: conflicting types for 'ps_get_thread_area'
 ps_get_thread_area (const struct ps_prochandle *ph,
 ^~~~~~~~~~~~~~~~~~
In file included from gdb_proc_service.h:25,
                 from amd64-linux-nat.c:50:
/usr/include/proc_service.h:72:17: note: previous declaration of 'ps_get_thread_area' was here
 extern ps_err_e ps_get_thread_area (struct ps_prochandle *,
                 ^~~~~~~~~~~~~~~~~~
make[4]: *** [Makefile:1081: amd64-linux-nat.o] Error 1
make[4]: Leaving directory '/mnt/opt/Sage/sage-dev/local/var/tmp/sage/build/gdb-7.8/src/gdb'
make[3]: *** [Makefile:8669: all-gdb] Error 2
make[3]: Leaving directory '/mnt/opt/Sage/sage-dev/local/var/tmp/sage/build/gdb-7.8/src'
make[2]: *** [Makefile:833: all] Error 2

this is with gcc-8.2.0 (with Gentoo patches)

Gdb 8.2 works. The tarball: https://ftp.gnu.org/gnu/gdb/gdb-8.2.tar.xz

Change History (5)

comment:1 Changed 3 years ago by dimpase

  • Description modified (diff)

comment:2 Changed 3 years ago by dimpase

  • Component changed from PLEASE CHANGE to packages: optional
  • Description modified (diff)
  • Type changed from PLEASE CHANGE to defect

comment:3 Changed 2 years ago by dimpase

  • Authors set to Dima Pasechnik
  • Branch set to u/dimpase/packages/gdb82
  • Commit set to 495650adb5bf3a77c9a688c6e460d51a1420b01f
  • Status changed from new to needs_review

New commits:

495650aupdate gdb to version 8.2

comment:4 Changed 2 years ago by jdemeyer

Duplicate of #24692

comment:5 Changed 2 years ago by jdemeyer

  • Milestone changed from sage-8.4 to sage-duplicate/invalid/wontfix
  • Resolution set to duplicate
  • Status changed from needs_review to closed
Note: See TracTickets for help on using tickets.