Opened 3 years ago

Closed 21 months ago

#26130 closed defect (fixed)

fflas_ffpack is not tested, tests fail

Reported by: gh-timokau Owned by:
Priority: major Milestone: sage-9.1
Component: packages: standard Keywords: darwin
Cc: vdelecroix, cpernet, dimpase, arojas, mkoeppe Merged in:
Authors: Timo Kaufmann Reviewers: Matthias Koeppe
Report Upstream: Fixed upstream, in a later stable release. Work issues:
Branch: 3ff111f (Commits, GitHub, GitLab) Commit: 3ff111f82f23bd20ce072571d21566774ea2810e
Dependencies: Stopgaps:

Status badges

Description (last modified by vklein)

While trying to port the nix build (and its dependencies) to darwin, @jbaum98 discovered that the fflas-ffpack tests are failing on darwin when using openblas. They don't fail on linux using openblas and they don't fail on darwin using another blas.

Trying to figure out if that is a nix issue or a fflas-ffpack / openblas issue, I compared our build with the sage spkg. I noticed that sage is not even running the fflas_ffpack tests. So maybe some issues with darwin have gone unnoticed.

I even get one test failure on linux:

FAIL: test-fgemm-check
======================

Checking ............................Modular<double> mod 67 ... PASSED with seed = 1535225205942725
Checking ........................Modular<double> mod 351293 ... PASSED with seed = 1535225205942726
Checking .........................Modular<double> mod 17659 ... PASSED with seed = 1535225205942727
Checking ....................ModularBalanced<double> mod 67 ... PASSED with seed = 1535225205942725
Checking ................ModularBalanced<double> mod 351293 ... PASSED with seed = 1535225205942726
Checking .................ModularBalanced<double> mod 17659 ... PASSED with seed = 1535225205942727
Checking .............................Modular<float> mod 13 ... FAILED
FAILED with seed = 1535225205942725
FAIL test-fgemm-check (exit status: 1)

Upstream issue: https://github.com/linbox-team/fflas-ffpack/issues/146

Change History (13)

comment:1 Changed 3 years ago by gh-timokau

  • Authors set to Timo Kaufmann
  • Branch set to public/26130
  • Commit set to a1b9e6ffda7ac536fb8c9f054f21e30b41cc615b
  • Component changed from PLEASE CHANGE to packages: standard
  • Keywords darwin added
  • Report Upstream changed from N/A to Reported upstream. No feedback yet.
  • Type changed from PLEASE CHANGE to defect

New commits:

a1b9e6fEnable fflas_ffpack tests

comment:2 Changed 3 years ago by git

  • Commit changed from a1b9e6ffda7ac536fb8c9f054f21e30b41cc615b to 3ff111f82f23bd20ce072571d21566774ea2810e

Branch pushed to git repo; I updated commit sha1. This was a forced push. New commits:

3ff111fEnable fflas_ffpack tests

comment:3 Changed 3 years ago by gh-timokau

  • Status changed from new to needs_review

Setting to needs_review since someone with acess to a darwin machine needs to test this.

comment:4 Changed 3 years ago by vdelecroix

  • Cc vdelecroix cpernet added
  • Milestone changed from sage-8.4 to sage-8.5

comment:5 Changed 3 years ago by vklein

On Darwin i get a fail with openblas too

$ sage -f -c fflas_ffpack
...
[fflas_ffpack-2.3.2] PASS: test-ftrmm
[fflas_ffpack-2.3.2] FAIL: test-fgemm-check
[fflas_ffpack-2.3.2] PASS: test-permutations
...

It look like it's a fflas-ffpack / openblas issue.

# file test-fgemm-check.log
Checking ..........................Modular<double> mod 1693 ... PASSED with seed = 1541770760090127
Checking .........................Modular<double> mod 12421 ... PASSED with seed = 1541770760090128
Checking ...........................Modular<double> mod 139 ... PASSED with seed = 1541770760090129
Checking ..................ModularBalanced<double> mod 1693 ... PASSED with seed = 1541770760090127
Checking .................ModularBalanced<double> mod 12421 ... PASSED with seed = 1541770760090128
Checking ...................ModularBalanced<double> mod 139 ... PASSED with seed = 1541770760090129
Checking ...........................Modular<float> mod 1693 ... PASSED with seed = 1541770760090127
Checking .............................Modular<float> mod 47 ... FAILED
FAILED with seed = 1541770760090128
FAIL test-fgemm-check (exit status: 1)

comment:6 Changed 3 years ago by gh-timokau

It'd be great if you can help upstream find the cause of it in https://github.com/linbox-team/fflas-ffpack/issues/173 :)

@jbaum98 had more test failures there, but this is one of them and he isn't responding. Maybe they have a common cause.

comment:7 Changed 2 years ago by vklein

  • Description modified (diff)
  • Milestone changed from sage-8.5 to sage-8.8
  • Report Upstream changed from Reported upstream. No feedback yet. to Fixed upstream, in a later stable release.

comment:8 Changed 2 years ago by vklein

  • Description modified (diff)

comment:9 Changed 2 years ago by embray

  • Milestone changed from sage-8.8 to sage-8.9

Moving tickets from the Sage 8.8 milestone that have been actively worked on in the last six months to the next release milestone (optimistically).

comment:10 Changed 22 months ago by embray

  • Milestone changed from sage-8.9 to sage-9.1

Ticket retargeted after milestone closed

comment:11 Changed 21 months ago by mkoeppe

  • Cc dimpase arojas mkoeppe added

comment:12 Changed 21 months ago by mkoeppe

  • Reviewers set to Matthias Koeppe
  • Status changed from needs_review to positive_review

comment:13 Changed 21 months ago by vbraun

  • Branch changed from public/26130 to 3ff111f82f23bd20ce072571d21566774ea2810e
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.