Opened 3 years ago

Closed 2 years ago

#26052 closed enhancement (fixed)

Update to OpenBLAS 0.3.3

Reported by: thansen Owned by:
Priority: major Milestone: sage-8.5
Component: packages: standard Keywords:
Cc: jpflori, vbraun, jdemeyer, moritz, aram.dermenjian, fbissey, embray, tscrim Merged in:
Authors: François Bissey Reviewers: Erik Bray
Report Upstream: N/A Work issues:
Branch: bdf02cf (Commits, GitHub, GitLab) Commit: bdf02cf06a95139a09567548b5f93021413a9e12
Dependencies: Stopgaps:

Status badges

Description (last modified by fbissey)

OpenBLAS 0.3.2 came out and was uploaded to Debian. When attempting to build the sage 8.3 Debian package (with one thread) with this version, OpenBLAS causes a crash during the docbuild, see attached log.

A bug in OpenBLAS that involves the same error message ("OpenBLAS : Program will terminate because you tried to start too many threads.") is https://github.com/xianyi/OpenBLAS/issues/1641

Our temporary workaround for now is to use Atlas (which we already used before for architectures which are not supported by OpenBLAS).

Please consider updating OpenBLAS in sage.

Openblas 0.3.3 is now out and the threading behavior which caused many bug reports is reverted for now. Prepared upstream tarball renamed to OpenBLAS-0.3.3.tar.gz

Attachments (1)

sage_8.3-openblas_error.log (36.3 KB) - added by thansen 3 years ago.

Download all attachments as: .zip

Change History (20)

Changed 3 years ago by thansen

comment:1 Changed 3 years ago by thansen

  • Cc jpflori vbraun jdemeyer moritz aram.dermenjian added

comment:2 Changed 3 years ago by fbissey

  • Cc fbissey added

comment:3 Changed 3 years ago by fbissey

I am not experiencing this problem in sage-on-gentoo. However I decided to only use "regular threads" and no "openmp threads" in openblas some time ago. I suspect that is why I am not affected at this stage. It may be that I have the wrong picture of threading in openblas as well.

comment:4 Changed 3 years ago by fbissey

I believe the problem has been addressed in 0.3.3 where they decided to switch back to the previous behavior with threads until they have fixed all the issues that have cropped in 0.3.2.

For the record I am using 0.3.3 (without openmp threads) in my own sage-on-gentoo builds.

comment:5 Changed 3 years ago by fbissey

  • Authors set to François Bissey
  • Branch set to u/fbissey/openblas-0.3.3
  • Commit set to bdf02cf06a95139a09567548b5f93021413a9e12
  • Description modified (diff)
  • Milestone changed from sage-8.4 to sage-8.5
  • Status changed from new to needs_review
  • Summary changed from Update to OpenBLAS 0.3.2 to Update to OpenBLAS 0.3.3

All the cygwin patches failed but most of the bits appears to have been merged upstream. Still someone should check cygwin with this release.


New commits:

bdf02cfupgrade to openblas 0.3.3

comment:6 Changed 2 years ago by tscrim

  • Cc embray tscrim added

comment:7 Changed 2 years ago by embray

I can confirm that the aforementioned cygwin-related patches should be safe to remove as I've had them accepted upstream for some time. I'll still want to run tests on this though. I think I can go ahead and get that started now.

comment:8 Changed 2 years ago by embray

I am rebasing this on 8.5.beta5 first though, though that shouldn't make too much difference.

comment:9 follow-up: Changed 2 years ago by embray

Also I'm getting invalid checksum when I use the tarball downloaded from github...?

comment:10 in reply to: ↑ 9 Changed 2 years ago by dimpase

Replying to embray:

Also I'm getting invalid checksum when I use the tarball downloaded from github...?

could you wget the tar file and rename it? That oh so clever github API might do something more than that...

comment:11 Changed 2 years ago by dimpase

hmm, no, indeed, it seems to be wrong (and as I came here from a duplicate ticket I had for the same task, I already had my tarfile all set...) What I get is md5 30e2f8d7317e84dde5a37152173848f1

comment:12 follow-up: Changed 2 years ago by embray

I'm not sure what you mean. That's exactly what I did. That's...disconcerting. I would hope that tarballs downloaded from GitHub wouldn't differ depending on when they were downloaded >_>

comment:13 Changed 2 years ago by dimpase

well, let us wait for NZ to comment on this

comment:14 Changed 2 years ago by embray

Either way I'm going ahead with building it.

comment:15 in reply to: ↑ 12 Changed 2 years ago by fbissey

Replying to embray:

I'm not sure what you mean. That's exactly what I did. That's...disconcerting. I would hope that tarballs downloaded from GitHub wouldn't differ depending on when they were downloaded >_>

Unfortunately, it is known to happen https://github.com/cschwan/sage-on-gentoo/issues/529 . It may be that the release are not cut properly since there are repos for which I have no issues. In any case github lets you upload your own tarball prepared with sdist and the like. And people should really do it.

So someone will have to host a reference tarball until it makes it to the sage mirror.

comment:17 Changed 2 years ago by embray

  • Reviewers set to Erik Bray

Ok, looks good to me otherwise.

comment:18 Changed 2 years ago by fbissey

  • Description modified (diff)
  • Status changed from needs_review to positive_review

Ok added the tarball matching the checksum in the description. Since Erik says he is happy with it I am switching it to positive review.

comment:19 Changed 2 years ago by vbraun

  • Branch changed from u/fbissey/openblas-0.3.3 to bdf02cf06a95139a09567548b5f93021413a9e12
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.