Opened 3 years ago

Closed 2 years ago

#25922 closed defect (duplicate)

Bug in is_postcritically_finite

Reported by: bellatobin Owned by:
Priority: minor Milestone: sage-duplicate/invalid/wontfix
Component: dynamics Keywords: Post-critically finite
Cc: Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description (last modified by chapoton)

is_postcritically_finite returns false for certain PCF functions.

Below is an example of the code in which PCF fails. I first applied is_postcritically_finite to the function, which output False and then found the finite critical orbits.

sage: P1.<x,y> = ProjectiveSpace(QQ,1);
sage: H = P1.Hom(P1);
sage: a = .5; c = 1.5;
sage: f = H([-2*a*x^3+3*a*x^2*y+c*y^3,y^3]);
sage: f.is_postcritically_finite()
False 

sage: f.critical_points()
[(0 : 1), (1 : 0), (1 : 1)]

sage: P = P1(0,1)
sage: f(P)
(3/2 : 1)
sage: f(f(P))
(3/2 : 1)

sage: Q = P1(1,1)
sage: f(Q)
(2 : 1)
sage: f(f(f(Q)))
(2 : 1)


Change History (5)

comment:1 Changed 3 years ago by chapoton

  • Description modified (diff)

comment:2 Changed 3 years ago by bhutz

  • Milestone changed from sage-8.4 to sage-duplicate/invalid/wontfix

oops. I missed the fact this was already opened as a ticket. I pushed the fix to #25939. The issue is in canonical height, not in is_postcritically_finite.

If you agree that 25939, fixes the issue in is_postcritically_finite, then mark this as positive-review so that it gets closed as 'duplicate'. If there are still further issues with is_pcf, then we can revisit this ticket for those fixes.

comment:3 Changed 3 years ago by chapoton

  • Status changed from new to needs_review

comment:4 Changed 3 years ago by bellatobin

  • Status changed from needs_review to positive_review

comment:5 Changed 2 years ago by embray

  • Resolution set to duplicate
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.